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Chapter 1: Overview of WebPublisher PRO 

Congratulations on your purchase of Inmagic® DB/Text® WebPublisher PRO! 

With WebPublisher PRO, you can publish, access, and maintain your Inmagic DB/TextWorks 
textbase information over the Internet or an intranet. Use it to manage Web site information 
within the framework of a textbase, instead of static HTML documents. 

This manual explains how to use WebPublisher PRO together with Inmagic DB/TextWorks® to 
publish textbases on the Web. 

Although they are separate applications, the two products are closely related, and you need both 
of them to publish information on the Internet or an intranet. 

• 

• 

• 
• 

• 
• 

DB/Text WebPublisher PRO is a Web publishing and information retrieval tool, which 
accepts queries from standard Web browsers, such as Microsoft Internet Explorer, and 
accepts XML function calls. The software returns search results in dynamically generated 
HTML and XML reports, and allows for editing over the Web. 

DB/TextWorks is the “buildware,” the database software that you use to build the textbases 
(text databases) that you want to publish. DB/TextWorks is a textbase system—a type of 
database software that enables you to build networked and standalone textbases to manage 
text, numbers, dates, and electronic images. DB/TextWorks combines traditional database 
power, including the ability to manipulate data and perform arithmetic calculations, with the 
ability to handle large amounts of text. 

DB/Text WebPublisher PRO is ideal for publishing text-intensive information that is likely to 
change on a regular basis, including: 

Catalogs and other information products on an intranet or the Web. 
Intranet publishing, such as Human Resource policies and competitive 
intelligence documents. 
Customer or prospect services, such as Help Desk, knowledgebase, and product catalogs. 
Research and resources for a company project, to which users can add URLs of relevant 
Web sites they discover. 

WebPublisher PRO consists of program files that accept queries and actions submitted over the 
Web and return results in dynamically formatted HTML or XML output. For the Webmaster or 
knowledge management specialist, this means there is no interface for WebPublisher PRO; there 
is no icon on the desktop or on your Windows Start menu. 
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A Web interface is designed either using the WYSIWYG tools within DB/TextWorks, or with 
third-party tools (such as, Microsoft FrontPage). If you choose the latter, you submit actions to 
WebPublisher PRO using XML syntax to enable your interface to query your DB/TextWorks 
textbase. For information about the XML syntax accepted by the software, see the Inmagic Web 
Products Technical Notes and the schema documentation, both located at 
http://support.inmagic.com/web. 

Terminology 
This manual uses the following terms. For other definitions, see the  on page 89. Glossary

• Webmaster. The Web server administrator. 

• Textbase designer or textbase administrator. The person who uses DB/TextWorks and 
WebPublisher PRO to prepare textbases for Web access. 

• User. The person who searches a textbase by means of a Web browser. 

• Search screen, query screen, HTML search page. An HTML page created with 
DB/TextWorks to allow users to search a textbase over the Web. 

• Edit screen, edit page. An HTML page created with DB/TextWorks to allow users to add, 
edit, and/or delete records in a textbase over the Web. 

2 Chapter 1: Overview of DB/Text WebPublisher PRO 

http://support.inmagic.com/web


WebPublisher PRO Features 
With WebPublisher PRO, your users can: 

• 

• 

• 

• 

• 

• 

• 

• 

• 

Search for records via the Web. Access records via a Web browser from any computer 
with an Internet connection (or an intranet connection if you are publishing to your 
intranet). 
View actual data for which they can search. Users can click a button to see actual data 
from the textbase. They can paste words to search for, to find exactly what they want. 
Experience fast, precise searching. Searching is fast and precise, even through thousands 
of records. 
Search using various methods. Users can search multiple fields or run predefined 
searches, just by clicking a link. They are not limited to a single, broad keyword search that 
can turn up hundreds of unwanted hits. Instead, they can search multiple fields at the same 
time, achieving a high accuracy rate. For example, rather than searching for liberal 
arts colleges and getting 700 hits, they can search for co-ed liberal arts 
colleges in New England that have fewer than 2,500 students and get a 
more precise list of hits. 
Search more than one textbase at a time. Users can search multiple textbases with a 
single Web query screen. For example, a user can search separate textbases containing 
books, periodicals, and research papers at the same time for a particular author. The results 
are formatted in a single, dynamically generated HTML report. (Note that this feature is not 
available for XML input/output.) 
View information in dynamically created displays. Searches in WebPublisher PRO 
retrieve the most up-to-date information in the textbase at that moment.  
View information in any number of ways. Content (records in the textbase) and format 
(layouts that you design) are controlled separately, so users can see multiple views of the 
same data (for example, a brief summary of information in tabular format or all information 
in a particular record). Compare this to viewing a static HTML page, where the content and 
format are one and the same. 
Calculate, sort, and manipulate data. Data can be manipulated in a variety of ways and 
the results are displayed dynamically on the Web. 
Modify records in a textbase from the Web. Users can add, edit, and/or delete records in a 
textbase from a Web browser. This is done using forms and screens designed in 
DB/TextWorks or with a custom-built interface that submits XML to WebPublisher PRO. 
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How WebPublisher PRO Works 
By combining its searching power with Extensible Markup Language (XML) and Simple Object 
Access Protocol (SOAP) capabilities, WebPublisher PRO lets you to integrate your 
DB/TextWorks textbases with other applications. This means you can create interactive forms 
using standard third-party tools (such as, Microsoft FrontPage). 

WebPublisher PRO is a powerful tool that enables you—regardless of your level of HTML and 
XML expertise—to design screens and forms so your users can search, display, and edit records 
over the Web. 

The software can be used in two distinct ways: 

• 

• 

As a WYSIWYG tool. Using the designers in DB/TextWorks, you can design forms and 
screens for Web use in a WYSIWYG (what you see is what you get) manner. The software 
does the HTML formatting for you. This method is for those who may not have access to a 
Web designer with XML/XSL know-how, and for those whose needs do not require 
custom-built Web interfaces. It enables a non-Web designer to easily create a Web interface 
from within the software. Your users can search a textbase, view results in a variety of 
ways, and add, edit, and/or delete records from a Web browser. 
With an XML/XSL custom interface. Using a third-party tool (for example, Microsoft 
FrontPage), you can build your own Web interface. Then, using the read-write XML 
features of WebPublisher PRO (including the ability to query a DB/TextWorks textbase via 
the Web using XML), enable that interface to search, add, edit, and/or delete records in your 
textbase over the Web. This method is for advanced designers, or for those with access to a 
Web designer with XML/XSL skills. 

This manual discusses the WYSIWYG way of using the software. Note, however, that many of 
the HTML-based settings for the WYSIWYG method are detailed in the Inmagic DB/TextWorks 
User’s Manual. You will be referred to that manual, when appropriate. 

For information about using the software with an XML/XSL custom interface, see the Inmagic 
Web Products Technical Notes, an HTML document available at the Inmagic Web site 
(http://support.inmagic.com/web). 

4 Chapter 1: Overview of DB/Text WebPublisher PRO 

http://support.inmagic.com/web


How Do WebPublisher PRO and DB/TextWorks Work Together? 
WebPublisher PRO combines the power of a Database Management System (DBMS) with the 
speed and flexibility of a text-retrieval system, to provide a superior method of Web site 
maintenance, access, and presentation. 

Instead of having to produce separate, static HTML pages for your Web site, you can place 
information in a DB/TextWorks textbase and put that textbase on your server. Now anyone who 
goes to your Web site can search your textbase to find the information they need. 

WebPublisher PRO can run in an Internet or intranet environment. The following illustration 
shows a typical LAN/WAN topology. 

 

WebPublisher PRO resides on 
the Web server, where it 
processes queries. 

DB/TextWorks resides on a 
local machine, where the 
administrator can access it. 

The following components are involved: 

• Browser Software. The only user requirement is a Web browser, which users point to a 
search screen to submit queries and display results. 

• HTTP Server Software. Passes information between the browser and WebPublisher PRO. 

• WebPublisher PRO. Processes queries from your users and returns dynamically formatted 
results. There is no Windows user interface. 

• DB/TextWorks. The buildware, a database application that the textbase designer uses to 
create and maintain textbases, forms, and HTML search and edit screens. 
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Documentation and Other Resources 
This manual assumes that you have a basic understanding of Internet issues and terminology, 
including HTML, URL, and the World Wide Web. It also assumes that you are familiar with 
DB/TextWorks and that you know how to create textbases, forms, query screens, and menu 
screens. For information about DB/TextWorks, see the Inmagic DB/TextWorks User’s Manual and 
the DB/TextWorks online help. 

In addition to this manual, you can use the following resources to learn about 
WebPublisher PRO:  
• Cars textbase. A sample textbase you can use with the tutorial exercises in Chapter 9. 

• Online help. Help for WebPublisher PRO is integrated in the DB/TextWorks online help, to 
explain the many DB/TextWorks features that support WebPublisher PRO. To access the 
help, start DB/TextWorks, choose Help>Help Topics or press F1. 

• README.HTM. An HTML document that contains important information for textbase 
designers and Webmasters. It is located in the WebPublisher PRO installation directory. It 
also details recently implemented WebPublisher PRO features. 

• Knowledgebase and Web site. Start DB/TextWorks and choose Help>Inmagic on the 
Web>Knowledgebase to go to the Inmagic Product Support knowledgebase on the Web, 
where you can search for solutions to common problems. Visit the Inmagic Web site 
(www.inmagic.com) by choosing Help>Inmagic on the Web>Home Page or Help>Inmagic 
on the Web>Support Page. 

• Inmagic Web Products Technical Notes. An HTML document that explains how to use 
XML input with Inmagic Web products. It is located on the Inmagic Web site 
(http://support.inmagic.com/web). 

• Inmagic Web Products Schema Documentation. An HTML document that describes the 
input schema for Inmagic Web products. It is located on the Inmagic Web site 
(http://support.inmagic.com/web). 

• HTML help pages for users. HTML pages that explain query methods and error messages. 
For more information, see “ ” on page 14. How Users Get Help
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Chapter 2: User Requirement and Resources 

This chapter explains how your users use WebPublisher PRO, and discusses documentation 
provided for them. 

How Do Users Use WebPublisher PRO? 
If you design your Web interface using the WYSIWYG tools in DB/TextWorks (that is, with the 
Query Screen Designer, Form Designer, and/or Menu Screen Designer), anyone with a Web 
browser can point to an HTML search screen and submit a query.  

To help make searching and editing more intuitive, you can include Word Wheel buttons and 
choices drop-down lists to query screens, or add validation list links to edit pages. 

If the textbase has passwords, you can add a password box to search or edit screens so users can 
enter a password. The password can restrict access to the textbase as a whole, or to particular 
fields and/or individual records. 

You can also design a menu screen containing predefined queries. This lets your users click a 
link to submit a query for which you have already specified the criteria. This can be useful if 
your users will be submitting the same query on a regular basis. 
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Searching with Word Wheels and Choices Drop-down Lists 
When searching, users can select items to search for from a Word Wheel or choices drop-down 
list. 

 

Word Wheel button 

Choices drop-down list

Tip! You can add Boolean drop-down lists in front of each box on a Web query screen. If you 
do this, users can select AND, OR, NOT from the drop-down list to control how multiple 
criteria are combined. 

If a user clicks a Word Wheel button, a dialog box that shows indexed information from the 
textbase opens. 

 

To use Word Wheels, users 
need specific versions of 
Microsoft Internet Explorer or 
Netscape Navigator. For 
browser requirements, click the 
Help button to open an HTML 
page (WEB_WW.HTM) and see 
the “Troubleshooting: Word 
Wheel” section. 
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A choices drop-down list lets users select an item from a list and is useful for fields that contain 
just a few entries. 

 
For information on how to include Word Wheels and choices drop-down lists on the search 
screens you design, see “ ,” the “

” section on page 43 and the “
” section on page 44. 

Chapter 5: Designing Query Screens for Web Use Adding Word 
Wheels to a Query Screen Adding a Choices Drop-down List to a 
Query Screen

Using Validation List Links on Edit Screens 
When users are adding or editing records over the Web from an edit screen, they can click a 
validation list link to open the Inmagic Choices Browser window and paste entries from a 
validation list. 

When a field has a validation list, its box label is turned into a hypertext link. 
This box label appears as 
a hypertext link to the 
Inmagic Choices Browser 
window. 
 
When a user clicks the link, the Inmagic Choices Browser window opens and displays the items 
from the field’s validation list. The user can select and paste entries from the list. 

 
For information on how to include validation list links on edit screens you design, see “

,” the “ ” section on page 34. 
Chapter 

4: Creating Forms for Web Use Creating Validation List Links
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Using Predefined Queries on a Menu Screen 
A Web menu screen is an HTML page that includes one or more predefined queries. To the user, 
the predefined queries look like regular hypertext links. 

If you design a menu screen, users can click links to submit queries you predefine, without 
having to enter query criteria in a query screen. 

For more information about designing menu screens for the Web, see “
” on page 53. 

Chapter 6: Designing 
Menu Screens for Web Use

 

On a menu 
screen, users 
click links to 
run 
predefined 
queries. 
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Viewing the Results of a Query 
When a user submits a query—either by clicking a link on a menu screen or clicking the Submit 
Query button on a Web search screen—the search criteria are passed to WebPublisher PRO, 
which performs the query, optionally sorts the records, formats the results (or an initial subset of 
results), and returns the information to the Web browser in HTML format. 
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The user can use the standard Web browser controls to look at the records, return to the home 
page, print, and so forth. WebPublisher PRO provides additional controls, such as navigation 
buttons on the report. 

Record appearance is controlled by forms that are designed with DB/TextWorks. Users can 
change record appearance dynamically by selecting different forms from a drop-down list on the 
page. If the textbase designer created a form with New record, Edit record, and/or Delete record 
links, users can add, edit, and/or delete records over the Web. 

The following illustration shows the same records from the previous illustration, but after the 
user selected a different form. The form selected contains pictures, more information, and Edit 
record and Delete record links. 

 

A user can click the 
Edit or Delete link 
to open the record 
in an edit screen 
from which he or 
she can edit or 
delete the record. 

12 
 

 
A user can select a different 
form to see a different view of 
the records. 
Chapter 2: User Requirement and Resources 



Forms that display multiple records (such as the forms in the previous two illustrations) often 
include a hypertext link to a single-record display. Users can click the link to see a detailed view 
of one record at a time. This is called expanding a record. For example, if you click the first 
Porsche link on the report shown in the previous illustration, you see a single-record display. 

 

An expanded 
view shows 
one record at 
a time. 
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After expanding a record, the user can perform some or all of these tasks: 

• 
• 
• 

• 

• 

• 

• 

• 

• 

• 

• 

Display the next or previous record using the Next Record or Previous Record buttons. 
If the textbase designer included Edit record or Delete record links, edit or delete the record. 
If the textbase designer included a New record link, open an empty edit screen to add a new 
record to the textbase. 
Change the appearance of the record by selecting a different form from the form drop-down 
list. 
Return to the report by clicking the Rewind button (<<), or the Close button if the expanded 
record opens in a separate browser window. (For more information about the parameter 
needed for an expanded record to open in a separate browser window, see the DB/TextWorks 
online help.) 
Print the record using the currently selected form to format the output. The Web browser 
software may also have an effect on output (for example, by numbering pages). 
Return to the query or menu screen using the New Search button. Note that you must add a 
parameter to the DBTWPUB.INI file for this button to appear, and the expanded record 
must open in the same browser window as the report. This feature is also available on the 
report page. For more information, see the DB/TextWorks online help. 

How Users Get Help 
WebPublisher PRO includes several HTML help pages: 

WEB_BEGIN.HTM. Explains how to perform a query and display results. Users can view 
this page by clicking the Help icon on an HTML query screen in the Web browser.  
WEB_WW.HTM. Explains how to use the Word Wheel. Users can view this page by 
clicking the Help button in the Word Wheel dialog box in the Web browser. 
WEB_ICHOICES.HTM. Explains how to use the Inmagic Choices Browser to paste 
entries from a validation list into an edit screen on the Web. 
WEB_MSG.HTM. Displays an alphabetical list of default error messages. Intended 
primarily for administrators, although you may allow users access. Users can view this page 
from links on the .HTM help pages mentioned above, where provided. Note that the 
administrator can change the text of the message, if needed. 

The textbase designer is free to make changes to these pages. After making changes, check all 
links in a browser to make sure everything works as intended. 
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Chapter 3: Getting Started 

With DB/TextWorks and WebPublisher PRO, you have all you need to create a textbase and 
design Web query screens, menu screens, and forms to display and edit information. This 
chapter details what you need to do to get started. 

Creating a Textbase 
Before your can start designing forms and screens for Web use, you need a textbase. 

Use DB/TextWorks to create a textbase, defining the fields you want, as well as the features for 
each field (for example, validation). 

This section provides basic information about creating a textbase. For more detailed information, 
see the DB/TextWorks User’s Manual or the online help. 

To create a textbase in DB/TextWorks 
1. Start DB/TextWorks. 

2. Choose File>New Textbase to open the Specify New Textbase dialog box. 

3. In the File name box, enter the name of the textbase you want to create (for example, type 
Marketing), then click the Save button. 

4. On the Create Textbase Structure dialog box, select the Define New Textbase option 
button, then click OK. 

5. On the Edit Fields dialog box, specify the fields you want to make up your textbase. For 
example, type Title in the Field Name box, then click the Add button. 

6. On the Type and Indexing tab, select a field type for the field from the Field Type 
drop-down list. If applicable to your needs, specify the appropriate indexing and Special 
Filing options on this tab, as well. Click the Change button when you are done. 

Note: You can use the other tabs on this dialog box to specify other attributes for your field 
(for example, specify a validation list). Click the Help button on the Edit Fields dialog box 
for more information about these tabs. 

7. Repeat steps 5 and 6 for each field you want to include in the textbase. 

8. Click Close. 
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9. On the Edit Textbase Structure dialog box, click OK. 

10. A message notifies you that the textbase is empty. Click OK to dismiss the message and 
open the Edit window. The Edit window displays a New Record edit form, so you can add 
records. 

11. Add a record to the textbase. Type information in the boxes, then choose Record>Save 
Records. To add another record, choose Records>New Record. 

Specifying Web Options in the Textbase Structure 
When publishing a textbase on the Web, there are several Web options that you may want to 
apply. 

Use the Edit Textbase Structure dialog box (choose Maintain>Edit Textbase Structure) to 
specify the following, as applicable: 

• 

• 

• 

Passwords. You can apply a Master, Field Access, and Silent password to restrict access to 
the textbase entirely, to certain fields, or even to specific records. Passwords work on the 
desktop and the Web. However, to use them on the Web with WebPublisher PRO, you must 
add a password box to a query screen or edit form. For more information, see “

” on page 17. 
Using 

Passwords on the Web
Sort Order. The order in which records display on the Web is controlled by the form used 
to display the information. However, if a form does not have a compulsory form sort 
applied, sorting is determined differently, depending on whether you are using HTML 
output (using forms designed in DB/TextWorks) or XML output (using a custom-built 
interface created outside of DB/TextWorks). For more information, see “

” on page 18. 
Sorting on the 

Web
XML Match Fields. If you plan to edit records over the Web using edit forms you create in 
DB/TextWorks, you should specify XML match fields to uniquely identify the record in the 
textbase that WebPublisher PRO is being asked to modify. For more information, see 
“ ” on page 19. Specifying XML Match Fields

Note: There are other textbase options that can be applied to a textbase from the Edit Textbase 
Structure dialog box, although they are not specific to textbases used on the Web. For more 
information about these other options, click the Help button on the Edit Textbase Structure 
dialog box or see the Inmagic DB/TextWorks User’s Manual. 

16 Chapter 3: Getting Started 



Using Passwords on the Web 
You can assign passwords to a textbase to restrict access to the textbase as a whole, to certain 
fields, and/or to individual records. 

The Master, Field Access, and Silent passwords you define in the textbase structure (choose 
Maintain>Edit Textbase Structure, then click the Passwords button) are applicable to the 
Web. For information about assigning passwords to a textbase, see the Inmagic DB/TextWorks 
User’s Manual. 

To use passwords on the Web, you must add a password box to a query screen or edit form so 
users can enter their password. 

Tip! This can be useful on intranets, where the textbase administrator can assign passwords to 
allow certain users access. This can also be useful on the Internet for limiting access to a 
textbase on your Web site, perhaps if you are charging for services offered. Only those users 
who request and obtain a password—after submitting payment, for example—can gain access to 
the textbase. 

Consider the following when deciding whether to use passwords on the Web: 

• 

• 

• 

If a textbase has Field Access and/or Silent passwords assigned, and you do not put a 
password box on the query or edit screen, the Silent password is used. 
If the screen has a password box but the user does not type anything in it, the Silent 
password is used. If the textbase has passwords, but no Silent password has been defined, 
then the screen must have a password box into which the user can type a password. If not, 
no one will be able to gain access to the textbase from that screen. 
When you use a query screen with a password box on the Web, the software automatically 
retains the password throughout your current browser session. For example, if a user 
submits a search, edits a record, then clicks the Rewind (<<) button to return to the query 
screen, the password box will still be populated with the password. Keep this in mind when 
deciding whether to add a password box to an edit screen. If there is a password box on the 
query screen, it may not be necessary to have another one on the edit screen. 
Important! For the password to be remembered during the current browser session, cookies 
must be enabled for that Web browser. 

For details on how to add a password box to a query screen see “
” on page 45. For details on how to add a password box to an edit form, see 

“ ” on page 27. 

Adding a Password Box to a 
Query Screen
Adding a Password Box to a Web Edit Form
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Sorting on the Web 
When records are displayed on the Web, sort order is determined by the textbase default sort 
order (choose Maintain>Edit Textbase Structure) or by the compulsory form sort specified for 
the form selected in the Web browser. 

The user has no way to sort records, so you should consider adding a compulsory sort to Report 
forms that you design for the Web, unless the textbase default sort is suitable. To specify a 
compulsory sort, choose Report Options>Compulsory Sort in the Form Designer. 

The following Compulsory Sort options are ignored, because they can change the perceived 
number of records retrieved: Exploded Sort, Interfile, and Omit Those Records (click 
Primary Sort Field Options). 

Sorting records is explained in detail in the Inmagic DB/TextWorks User’s Manual and in the 
online help. 

If you are using WebPublisher PRO with a custom-built XML interface, you can specify the sort 
order in the XML input you submit to the software. For more information, see the Inmagic Web 
Products Technical Notes, located at http://support.inmagic.com/web. 
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Specifying XML Match Fields 
When editing or deleting records over the Web, WebPublisher PRO uses match fields to 
uniquely identify the record it is being asked to modify in the textbase. XML match fields are 
defined in the textbase structure (choose Maintain>Edit Textbase Structure, then click the 
XML Match Fields button). 

When you are editing or deleting a record and click the Submit Record or Delete button, the 
software compares the match field(s) to the records in the textbase to ensure the correct record is 
updated/deleted. 

You can match on up to five fields; however, in most cases, one field is sufficient. The 
combination of match fields must contain unique contents, such as an Automatic Number or 
other unique identifier (for example, employee identification number). If you match on only one 
field, that field should be present and unique in every record. To be sure, you can use an 
Automatic Number field, or a field with Unique Entries Only and Field Entry Required 
validation applied. 

When editing an existing record over the Web, you cannot change the contents of any of the 
match fields. 

Note: If you do not specify any match fields on the Specify XML Match Fields dialog box, 
WebPublisher PRO uses the first field specified on the Textbase Log File dialog box. 

To specify XML match fields 
1. With your textbase open, choose Maintain>Edit Textbase Structure to open the Edit 

Textbase Structure dialog box. 

2. In the Textbase Options group, click the XML Match Fields button to open the Specify 
XML Match Fields dialog box. 

3. From the Available Fields list, select a field on which you want WebPublisher PRO to 
match. 

4. Click the right-arrow button to move this field from the Available Fields list to the Match 
Fields list. Only Term-indexed fields can be used for matching purposes. Fields that do not 
have a Term index do not appear in the list. 

5. Repeat for each match field you want to use, up to a maximum of five. 

Note: The combination of fields must uniquely identify the record. 

6. Click OK. 

Important! XML Match Field information is stored in the textbase .INI file. If you copy the 
textbase to your Web server, be sure to copy this file, as well. When editing or deleting records 
over the Web, WebPublisher PRO uses match fields to uniquely identify the record it is being 
asked to modify in the textbase. 
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Publishing on the Web with WYSIWYG Tools 
For those who may not have access to a Web designer with XML/XSL know-how, you can 
design your own forms and screens using the three designers within DB/TextWorks: Form 
Designer, Query Screen Designer, and Menu Screen Designer. 

Use the following steps as a guide to publishing a textbase on the Web with the WYSIWYG 
tools of DB/TextWorks. 

To publish a textbase on the Web 
1. Create the textbases. Use DB/TextWorks to create textbases that Internet/intranet users 

will search. Put the textbases anywhere that WebPublisher PRO can access them. The 
textbases can be in a shared location, or you can store the textbase locally and copy it up to 
the HTTP server whenever you make a change. 

2. Create the forms. Use the Form Designer in DB/TextWorks to create forms that will be 
used to display records in the Web browser. You should design one or more Report forms 
for displaying multiple records retrieved, and one or more Display forms for expanded 
display of one record at a time. If you plan to let users add, edit, and/or delete records over 
the Web, you should design one or more Edit forms. 

Tip! Tabular report forms, which present information in rows and columns, are a useful way 
to display a summary of records found after a search. The user can expand each record to 
see more information. For more information about tabular forms, see the Inmagic 
DB/TextWorks User’s Manual. 

In the Form Designer, be sure to choose Tools>Box Properties>HTML and Tools>Form 
Properties>Logos/HTML and specify HTML attributes. 

Note: If you want to provide your users with direct Web access to an edit screen from which 
they can add records (for example, a registration form for an event), create an Edit form and 
export it to HTML. Edit forms are the only type of form that can be exported to HTML. For 
more information, see “ ” on page 37. Exporting Editing Screens to HTML

3. Save the forms. When you save each form in the Form Designer, select these options:  

– Save in Textbase File (Public). This ensures that when you place the textbase files on 
the server the forms will be there too. 

– Web from the Use For group. 
– One or more of the following from the Use For group, depending on the purpose of the 

form: 
 Display Window. Select this check box to have this form appear in the expanded 

display form lists on the Web. 
 Report Window. Select this check box to have this form appear in report form 

lists on the Web. 
 Edit Window. Select this check box to enable the form to be used to add, edit, and 

delete records over the Web. 
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Note the following important issues about forms: 

– Forms are not separate files. They are saved in the textbase, so you do not have to take 
any extra steps to place forms on the server, nor do you have to convert them to HTML. 
The software performs HTML formatting for you. 
Note: This is true of all forms except edit forms you plan to allow users to access 
directly on the Web to add records to your textbase. If this is the case, you must save 
the form for use in the Edit Window, and it must be exported to HTML. 

– Use Tools>Screen Properties>HTML for query screens, and Tools>Box 
Properties>Initial Elements for menu screens to specify which Report, Display, and 
Edit forms to use initially in the Web browser. 

– Printed reports use whichever form is displayed in the browser when the browser Print 
command is used. 

4. Create an HTML query search screen. A query screen is a search form that users type 
query criteria into, in order to search for records. Use the Query Screen Designer to design a 
query screen, then export it as HTML. Place the resulting HTML page anywhere on your 
Web site. 

5. [Optional] Create an HTML menu screen. You can use a menu screen instead of, or in 
addition to, a query screen. A menu screen is a list of one or more predefined searches. The 
searches appear to a Web user as a list of hypertext links. Clicking a link generates a search 
and returns records to the Web browser. Use menu screens when you want to “protect” 
users from having to specify query criteria, or when many users are likely to want to 
perform the same searches. Use the Menu Screen Designer to create a menu screen and 
export it to HTML. 

6. Give users a way to get to the query screen or menu screen. Put the HTML page 
anywhere accessible to the HTTP server. Then make sure that Web users have a way to get 
to that page. For example, add a hypertext link to a page on your Web site that jumps to the 
HTML page. Or make your home page the query screen or menu screen itself. If you are 
publishing multiple textbases, a page on your Web site could include a list of the textbases, 
with each item being a jump to the appropriate HTML query screen. 

7. Test your textbases. Before you make your textbases widely available on the Internet or an 
intranet, test them locally to be sure that everything works the way you intended. 
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Chapter 4: Creating Forms for Web Use 

You design forms for use with WebPublisher PRO the same way you design forms for 
DB/TextWorks—using the Form Designer. 

However, unlike forms created for the desktop, there are several HTML properties you can add 
to a form that is used on the Web. 

HTML properties can apply not only to forms as a whole, but also to individual boxes within 
forms. You can select Web-specific properties from the menu locations listed below.  

• 

• 

Tools>Form Properties>Logos 

Tools>Form Properties>HTML 

• Tools>Box Properties>HTML (form and text boxes) 

These properties only affect forms used on the Web. They are ignored for forms used on the 
desktop. 

For details about designing forms in general (that is, adding form boxes, background color, and 
so forth), see the Inmagic DB/TextWorks User’s Manual. 
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Adding Logos to a Form 
Use the Logos tab on the Form Properties dialog box (choose Tools>Form Properties>Logos) 
to add images to the top and/or bottom of a form. 

 
Type the image name in the Leading Logo and/or Trailing Logo box, or click the Browse 
button to navigate to it. 

For more information, click the Help button on the dialog box, or see the Inmagic 
DB/TextWorks User’s Manual. 

For information on image file locations, see “ ” on 
page 69 of this manual. 

Logo and Background Image File Locations
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Adding HTML Properties to a Form 
Use the HTML tab on the Form Properties dialog box (choose Tools>Form 
Properties>HTML) to add HTML-related properties to a form. You can specify that record 
separators be used, add a background image to the form, and/or add HTML to the <head> 
section of the page. 

 
For details about these settings, see the Inmagic DB/TextWorks User’s Manual, or click the Help 
button on the dialog box. 
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Using HTML Properties in a Tabular Form 
If you are designing a tabular form, the options on the HTML tab of the Form Properties dialog 
box differ slightly from those available for non-tabular forms. While you can specify a 
background image for the page and include HTML in the <head> section of HTML reports, 
there are no settings for record separators. This is because records appear in a table, with each 
row designating a record. 

This tab also lets you specify the width (in pixels) of the border around the table. 

 
For details about these settings, see the Inmagic DB/TextWorks User’s Manual, or click the Help 
button on the dialog box. 
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Adding HTML Properties to Form and Text Boxes 
When designing a form, use the HTML tab on the Form Box Properties and Text Box Properties 
dialog boxes to specify Web-only features. 

There are several HTML properties that you can add to form and text boxes: 

• 

• 

• 

Validation list links. [Form boxes only.] Specify that you want the field(s) in a specific 
form box to have a validation list link on Web edit forms. The field(s) must have a 
validation list. Users click the link to open the Inmagic Choices Browser and paste entries 
into the edit form. This option is only applicable to Edit forms saved for use on the Web. 
(This option is only necessary if you have turned off the automatic validation list link 
feature and want to apply validation list links to individual fields on your edit form. For 
more information, see “ ” on page 35.)  Turning off automatic validation list links
Password boxes. [Form boxes only.] You can specify that a form box be used as a 
password box, so users can enter a password on a Web edit form. This option is only 
applicable to edit forms saved for use on the Web. Consider whether you want to add a 
password box, as an edit screen accessed after a search from a query screen with a password 
box will have that password carried through to the edit screen. 
Treat content item as/Treat text as. [Form and text boxes.] Use these drop-down lists to 
have the content item selected from the Contents list (for form boxes) or the text you specify 
(for text boxes) treated in the way you want (for example, as Raw HTML, as a URL, as a 
New record link). Each of the options you can select is detailed in the Inmagic 
DB/TextWorks User’s Manual. However, some of them are explained in the following 
section. 

Adding a Password Box to a Web Edit Form 
When you design an edit form for Web use, you can add a password box to the form so users can 
enter a password. 

Note: Passwords entered into a query screen are carried through to the edit form used, if you are 
editing over the Web. Take this into consideration when deciding whether to add a password box 
to an edit form. 

To add a password box to a Web edit form 
1. In the Form Designer, open the edit form you plan to use on the Web and add a form box 

(choose Edit>Add>Form Box). 

2. On the Form Box Properties dialog box, select the Labels tab and do the following: 

a. Select the Label check box. 
b. In the Label box, enter the label you want to appear on the box. For example, type 

Enter Password. 
c. From the Label position drop-down list, select an option to specify where the label 

appears (for example, Left or Top left.) 
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3. Save the form. If you have not done so already, select the Edit Window check box on the 
Save Form As dialog box (choose Form Operations>Save Form As). The form must be 
saved for use in the Edit Window for the Web box treatment drop-down list (see the next 
step) to be enabled. 

4. On the HTML tab, from the Web box treatment drop-down list, select Password. 

5. Click Apply, then Close. 

Using Raw HTML 
When designing query screens, menu screens, and forms for Web use, you can specify that box 
content be interpreted as Raw HTML (for example, to specify that a hypertext link to a new page 
opens a new browser window). 

To specify Raw HTML, add a form box or text box to a form, or add a text box to a query or 
menu screen. On the HTML tab of the applicable Box Properties dialog box, select Raw HTML 
from the Treat content item as/Treat text as drop-down list. 

Specifying Raw HTML causes the box content to be passed through to the Web browser. When 
the form is used on the Web, the browser will attempt to interpret the contents of the box as 
HTML. 

An example 
In the following example, Raw HTML is used to tell the software to open a particular HTML 
page in a new browser window. 

Note: These steps are applicable to forms, query screens, and menu screens. 

1. With the form or screen you want to use on the Web opened in the appropriate designer, 
choose Edit>Add>Text Box to add a text box and open the Text Box Properties dialog box. 

2. On the Text tab, in the Text box, enter the text you want interpreted as Raw HTML (for 
example, type <a href="searchform.htm" target="_blank">Click here 
to search.</a> to have the link created open a page called SEARCHFORM.HTM in a 
new browser window. 

3. Click Apply, then Close. 

When records are displayed in the browser using this form, the user will see this text in each 
record: 

Click here to search.  

Clicking the text will open the specified search form (SEARCHFORM.HTM) in a new browser 
window. 

The purpose of Raw HTML is to correctly interpret HTML that cannot otherwise be specified in 
the DB/TextWorks designers. For example, in the example above, if you did not want to open 
the form in a new window (that is, you remove target="_blank"), you do not need to use 
Raw HTML. Instead, treat the text as a URL and specify alternate link text. 
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Using a hypertext link to access another location on an Intranet 
On a suitably configured intranet, you can launch applications from a form, query screen, or 
menu screen. For example, a link on a report could open a document in Microsoft Word or run a 
video clip. Web users need network access to the necessary application(s) and files. Be sure to 
communicate this to the Webmaster in case there are firewall or security issues. For more 
information, see “Chapter 8: For the Webmaster” on page 63. 

The target file on the server should be accessible to all users, either by HTTP addressing 
protocols or by network file access protocols. Check with the Webmaster to find out which 
protocol to use. 

If you will use HTTP access, specify a link by selecting the appropriate option from the Treat 
content item as drop-down list (for form boxes) or Treat text as drop-down list (for text boxes) 
on the HTML tab of the applicable Box Properties dialog box. 

For more information, see Chapter 5 of the Inmagic DB/TextWorks User’s Manual, the “Using 
HTML in form boxes,” and “Using HTML in text boxes” sections. 

If you will use network file access, use the following steps to make WebPublisher PRO treat the 
content of a box as a file reference. 

To treat box content as a file reference 
1. Add the destination file name in the appropriate designer: 

– Form Designer: 
a. Choose Edit>Add>Form Box to add a form box and open the Form Box 

Properties dialog box. 
b. On the Fields subtab of the Contents tab, add a field that contains one or more file 

names, such as a field called Documents. 
– Query Screen Designer or Menu Screen Designer: 

a. Choose Edit>Add>Text Box to add a text box and open the Text Box Properties 
dialog box. 

b. On the Text tab, type the full path name for a document. For example, 
\\server\vol1\test\myfile.doc. 

2. With the Form/Text Box Properties dialog box still open, select the HTML tab. 

3. Select HTML file reference from the Treat content item as (form box) or Treat text as 
(text box) drop-down list. 

4. Click Apply. 

To avoid conflicts over logical drive mappings, specify the target file using a UNC file name, 
not a drive letter. 

If you want the link text to be different than the file name, select the Use alternate link text 
check box on the HTML tab, which is enabled when you choose HTML file reference from the  
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Treat content item/text as drop-down list. Type the text you want to use as the link in the Text 
box. For example: 

File name: 

\\server\vol1\test\myfile.doc 

Alternate text: 

Click here 

Result in report: 

<a href="file://server/vol1/test/myfile.doc">Click here</a> 

If a field contains multiple file names, the alternate text will be the same for each file. 

Adding an expand record link to a report 
When designing a report form for use on the Web, you can add an expand record link to provide 
a hypertext link to a single-record display page. 

That means that after a search, when records are viewed on the Web as a report (that is, showing 
multiple records that met the search criteria), a user can click the expand record link to see more 
detailed information (that is, opening a display page to show a different view of the 
information). 

You can add an expand record link to a report form using a text box or a form box. If you use a 
form box, you can use the content of the field as the link (for example, the title of a publication). 
If you use a text box, the link to the expanded view will be the text you type in the text box. 

The Display form specified as the Initial Display Form in the query screen determines how the 
expanded record appears. Be sure to design a Display form that will give users more information 
about a record. If you do not supply a Display form, the textbase default or Basic form is used 
instead. If you do not include an expand record link, the ability to expand a record is unavailable. 

To add an expand record link with a form box 
1. Open a report form in the Form Designer. 

2. Select a form box whose content you want to use as the hypertext link. 

3. Choose Tools>Box Properties to open the Form Box Properties dialog box. 

4. On the HTML tab, select a content item from the Contents list. We recommend you select a 
field that will be present and different in every record, such as the title of a publication. 

5. From the Treat content item as drop-down list, select Expand record link. 

6. Click Apply, then Close. 
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When this form is viewed on the Web, the content of the Title field will appear as a hypertext 
link to a more detailed view of the record. The following illustration depicts a tabular report 
form showing title, author, and summary information, with the expand record link applied to the 
form box containing the Title field. 

 

To add an expand record link with a text box 
1. Open a report form in the Form Designer. 

2. Choose Edit>Add>Text Box to add a text box and open the Text Box Properties dialog 
box. 

3. On the Text tab, type the text you want to appear as the expand record link in the Text box 
(for example, type More). 

4. On the HTML tab, from the Treat text as drop-down list, select Expand record link. 

5. Click Apply, then Close. 

When this form is viewed on the Web, the text you type in the text box becomes the expand 
record link to a more detailed view of the record. If the tabular form in the previous illustration 
used a text box with the word More as the expand record link (instead of the contents of the 
Title field) it might look like this: 
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Adding a “See Also” search link 
When designing a form for use on the Web, you can add a “See Also” search link to treat each 
entry in a field as a link that will search the textbase. 

For example, you can turn a field named Author into a “See Also” link that, when clicked, finds 
all other books by the same author. If this option is used and a book has multiple authors, each 
author becomes a link to his/her other works. 

To add a “See Also” search link to a form box 
1. Open a report form or display form in the Form Designer. 

2. Select a form box whose content you want to use as the “See Also” search link (for 
example, the box containing the Author field). 

3. Choose Tools>Box Properties to open the Form Box Properties dialog box. 

4. On the HTML tab, select a field from the Contents list. This is the field whose entries will 
be turned into “See Also” search links. 

5. From the Treat content item as drop-down list, select “See Also” search link. 

6. Click Apply, then Close. 
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Editing Over the Web 
With WebPublisher PRO, you can design edit forms in DB/TextWorks, which your users can 
use to add, edit, and/or delete records over the Web. 

You design edit forms for the Web using the Form Designer. 

To be able to edit over the Web, the designer must provide at least one of the following types of 
links on report, display, and/or edit forms. These links are specified using the HTML tab on the 
Form Box Properties or Text Box Properties dialog boxes (choose Tools>Box 
Properties>HTML). 

• 

• 

• 

• 

New record links. This type of link opens an empty edit screen from which a user can add a 
new record. You can add New record links to report forms and display forms (as well as to 
query screens). 
Edit record links. This type of link opens the current record in an edit screen from which a 
user can make changes. You can add an Edit record link to report and display forms. 
Delete record links. This type of link opens the current record in an edit screen from which 
a user can delete the record. You can add a Delete record link to report and display forms. 
Duplicate record link. This is a special type of link that can only be used on an Edit screen 
used on the Web. It creates an editable copy of the current record on the screen. When a 
user saves the record, the copy is saved as a new record. This type of link can only be 
created by using a New record link on a Web edit form. Typically, a duplicate record link is 
created with a text box containing text that makes the link’s purpose clear (for example, 
Copy Record). 

Creating New, Edit, and Delete Record Links 
New record, Edit record, and Delete record links have different purposes, but are created in a 
similar manner. 

To add a New/Edit/Delete record link to a form 
1. Open the form in the Form Designer. 

2. Add a text box or a form box, depending on what you want to do: 

– If you want to use text you type as the link to an edit or delete screen: 
a. Choose Edit>Add>Text Box to add a text box and open the Text Box Properties 

dialog box. 
b. On the Text tab, in the Text box, enter the text you want to appear as the link to an 

edit or delete screen. For example, if you are going to use this text as a New record 
link, type Add New Record. 

c. On the HTML tab, from the Treat text as drop-down list, select New record link, 
Edit record link, or Delete record link, as appropriate. 

d. Click Apply, then Close. 
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– If you want to use field content or other form box contents (for example, Fixed Text) as 
the link to an edit or delete screen: 
a. Choose Edit>Add>Form Box to add a form box or select an existing form box 

and choose Tools>Box Properties. The Form Box Properties dialog box opens. 
b. Select or add the content item whose content you want to use as the link to the edit 

or delete screen. 
c. On the HTML tab, from the Treat content item as drop-down list, select New 

record link, Edit record link, or Delete record link, as appropriate. 
d. Click Apply, then Close. 

Save the form for use on the Web and in the appropriate window (for example, Report 
Window, Display Window, Edit Window), depending on the type of form you designed. (Note 
that when the form is used on an edit screen, a New record link will make a copy of the current 
record in the edit screen, not open an empty edit screen; Edit and Delete record links will not 
appear.) 

Creating Validation List Links 
When adding and editing records on the Web, fields with a validation list defined in the textbase 
structure will have their box labels automatically turned into hypertext links on edit screens 
(unless you turn off this feature). 

Users click the hypertext link to open the Inmagic Choices Browser window, from which they 
can select items from the validation list. If a field uses a thesaurus as a validation list, the list will 
appear. Note, however, that non-preferred terms are not included. 

 
For information about using the Inmagic Choices Browser window, uses can click the Help 
button on the window to open an HTML help page. 
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Turning off automatic validation list links 
If you do not want all fields with a validation list defined in the textbase structure to have 
validation list links on Web edit forms, you can add a parameter to the INMAGIC.INI file to 
make it so. This file resides in your WebPublisher PRO installation directory. For example, if 
your textbase uses record-level security, you may not want to expose all of your record class 
values to your users. 

In the [WebPublisher] section, add the AutoIncludeValidationLinks=0 
parameter. 

[WebPublisher] 
AutoIncludeValidationLinks=0 

If the parameter is set to 0, only fields that you specify in the edit form will display validation 
list links (if those fields also have a validation list defined in the textbase structure). 

If the parameter is set to 1 (the default) all fields with a validation list will display a validation 
list link on Web edit forms. 

Important! You must stop and restart your World Wide Web Publishing Service for 
WebPublisher PRO to recognize changes made to the INMAGIC.INI file. 

To turn off automatic validation list links for edit forms that are exported to HTML, add the 
parameter to the [WebPublisher] section of the INMAGIC.INI file used by DB/TextWorks. 

To display validation list links on the Web 
1. In the Form Designer, open the Edit form you plan to use to on the Web for your users to be 

able to add, edit, and/or delete records. 

2. Select the form box containing the field for which you want to display a validation list link. 
This field must have a validation list specified in the textbase structure. 

3. Save the form for use in the Edit Window on the Save Form As dialog box (choose Form 
Operations>Save Form As). 

4. Choose Tools>Box Properties to open the Form Box Properties dialog box. 

5. On the HTML tab, from the Web box treatment drop-down list, select Validation.  

6. Click Apply, then Close. 

7. Repeat steps 2–6 for each form box for which you want a validation list link to appear. Note 
that fields must have a validation list specified in the textbase structure for validation list 
links to appear on the Web. 
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Using Default Values on a Web Edit Screen 
When you design an Edit form for use on the Web, you can specify that default information 
automatically appear in a specific field each time the edit screen is used to create new records. 
For example, if a user will be entering sales orders using a Web edit screen, you can design a 
custom edit form for each sales representative so that his or her name automatically appears in 
the Sales Rep field for each new record. This ensures that this field always has information in it, 
and reduces the amount your users have to type. 

Note: Default values only appear on Edit forms used to add new records (that is, edit forms 
accessed by a New record link or an edit form that has been exported to HTML). Default values 
will not appear on edit forms used to edit or duplicate existing records. 

To specify that default field information appear on a Web edit screen 
1. In the Form Designer, open the Edit form you plan to use on the Web to add new records. 
2. Select the form box that contains the field for which you want a default value inserted. For 

example, on a sales order edit form, select the form box containing the Sales Rep field. 
3. Choose Tools>Box Properties to open the Form Box Properties dialog box. (Notice that the 

field in the form box you selected in the previous step appears in the Contents list and is 
selected in the Fields list.) 

Note: To have a default value appear automatically on the screen, the field must be the first 
item in the form box. 

4. On the Fields subtab of the Contents tab, in the If empty use box, enter the default 
information you want to appear in the field when the Web edit screen opens in a browser. 
For example, type Marlena Bryce.  

5. Click the Replace button. 
6. Click Close. 
When this edit form is used to create new records on the Web, the name you typed in step 4 will 
appear automatically in the Sales Rep box. 
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Exporting Editing Screens to HTML 
If you only want to provide users the ability to add records to your textbase and want them to be 
able to have direct HTTP access to the edit screen, you can export an edit screen to HTML. 

This method is useful when you only want a user to be able to submit information to you (for 
example, a registration form for an event). 

Important! If you use this method, you are allowing your users to only be able to add records 
from a Web browser—they will not be able to edit or delete records over the Web using this 
form. 

To export an edit form to HTML 
1. In the Form Designer, open the form you want to export. 

2. Save the form for use in the Edit Window (choose Form Operations>Save Form As and 
select the Edit Window check box), if it has not been done already. 

3. Choose Form Operations>Export Editing Form to HTML. 

4. A message appears asking if you want to use Cascading Style Sheets to preserve the 
formatting you specified in the Form Designer. Click Yes to preserve positioning when the 
edit form is displayed on the Web. Click No to have DB/TextWorks use simple HTML to 
place elements on the edit form (that is, boxes will be left-justified, box labels will appear 
on top rather than to the left, and so forth). 

5. On the Save File As dialog box, do the following: 

– In the File name box, type a name for the HTML editing form. 
– Navigate the Save in drop-down list to the location in which you want to save the form. 

The location should be accessible to the HTTP server on which WebPublisher PRO is 
installed. 

– Click Save. 
6. Click OK to dismiss the completion message. 

Once your edit form has successfully been exported to HTML, your users can add records to the 
textbase over the Web. Using a Web browser, they can open the edit form, enter record 
information in the applicable fields, then click the Submit Record button. 

Tip! Be sure the textbase for which you have exported an editing form is accessible to 
WebPublisher PRO and that your DBTW-WPD virtual directory and IUSR account have the 
appropriate access rights. See the WebPublisher PRO installation notes for more information 
about access rights. 
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Chapter 5: Designing Query Screens for Web Use 

When you design a query screen for Web use, use the Query Screen Designer in the same way as 
you would to design one for the desktop. 

However, unlike query screens designed for the desktop, there are several HTML properties you 
can add to a query screen that is used on the Web. In addition, a Web query screen must be 
exported to HTML before it can be used on the Web. (For more information, see “

” on page 50.) 
Exporting 

Query Screens to HTML

HTML properties can apply not only to query screens as a whole but also to individual boxes 
within query screens. When you design query screens for the Web, you can select Web-specific 
properties from the menu locations listed below.  

• Tools>Screen Properties>Logos 

• Tools>Screen Properties>HTML 

• Tools>Box Properties>HTML (query and text boxes) 

• Tools>WebPublisher Multiple Textbase Query 

These properties only affect query screens exported to HTML for use on the Web. They are 
ignored for query screens used on the desktop. 
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Adding Logos to a Query Screen 
Use the Logos tab on the Screen Properties dialog box (choose Tools>Screen 
Properties>Logos) to add images to the top and/or bottom of a query screen. 

 
Type the image name in the Leading Logo and/or Trailing Logo box, or click the Browse 
button to navigate to it.  

For more information, click the Help button on the dialog box, or see the Inmagic 
DB/TextWorks User’s Manual. 

For information on image file locations, see “ ” on 
page 69 of this manual. 

Logo and Background Image File Locations
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Adding HTML Properties to a Query Screen 
Use the HTML tab on the Query Screen Properties dialog box (choose Tools>Screen 
Properties>HTML) to add HTML-related properties to a query screen. 

You can specify the initial report, display, and edit forms to be used by the Web browser; 
whether form drop-down lists appear on the Web; how many records to display per page; the 
location of navigational controls (such as, the Next/Previous buttons); and whether Boolean 
operators and a background images appear. 

 
For details about these settings, see the Inmagic DB/TextWorks User’s Manual, or click the Help 
button on the dialog box. 
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Adding HTML Properties to Query and Text Boxes 
When designing a query screen, use the HTML tab on the Query Box Properties and Text Box 
Properties dialog boxes to specify Web-only features. 

Query Boxes 
To specify HTML features for a query box, use the HTML tab of the Query Box Properties 
dialog box (select the query box and choose Tools>Box Properties). 

 
There are several HTML properties that you can add to a query box: 

• 

• 

• 

Word Wheels. When you specify that a box include a Word Wheel, a Word Wheel button 
appears to the right of the query box when viewed on the Web. Users click the button to 
open a dialog box that lists all indexed terms or words in the current field. The user can 
paste terms or words from the list into the query box. 
Choices drop-down lists. If a query box has a choices drop-down list, the user can click the 
down arrow on the drop-down list to see a list of indexed terms. (If there is no Term index, a 
list of words appears.) The user can select an item from the list to search for that item. 
Password box. You can specify that a query box be used as a password box, so users can 
enter a password on the Web query screen. 
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Adding Word Wheels to a Query Screen 
A Word Wheel is a dialog box that shows indexed information from the textbase. When you 
design a query screen, you can add a Word Wheel button next to a box, so it appears like this in 
the browser:  

 
Users can click the Word Wheel button to open a dialog box that shows information from the 
textbase. WebPublisher PRO generates Word Wheels dynamically, so they always show the 
most recent information. The Inmagic index-streaming technology downloads only the portion 
of the index that is needed, to minimize load on the server. 

The Word Wheel can show a list of words or terms (complete entries). The user selects a word 
or term from the Keys list, clicks Paste, then executes the query. 

 

Users select a term 
from the list, then 
click the Paste button. 

If the query box 
contains multiple 
fields, users select the 
field for which they 
want to see the 
Choices List from the 
Field drop-down list.  

To add a Word Wheel button 
1. Choose Search>Design Query Screen and open a query screen in the Query Screen 

Designer. 

2. Select the query box to which you want to add a Word Wheel. 

3. Choose Tools>Box Properties to open the Box Properties dialog box. 
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4. On the HTML tab, select the Add Word Wheel option button. By default, the Word Wheel 
will show a list of words. To show terms first, select the Show terms by default check box. 

Note: Users can switch between seeing words and terms by selecting the Words List and 
Terms List option buttons, as appropriate, on the Word Wheel dialog box. 

5. Click Apply, then Close. 

6. Save the query screen, then export it to HTML (see page 50 if you need help). 

Important! See the HTML help page supplied for the Word Wheel (WEB_WW.HTM) for 
browser requirements to run the Word Wheel. If you suspect that some users will have older 
browsers, you may want to provide access to two versions of the search screen—one with Word 
Wheels and one without. 

Adding a Choices Drop-down List to a Query Screen 
A choices drop-down list is a static list of indexed items in a field. The list is generated when 
you export the query screen to HTML. Drop-down lists can be seen in Web browsers but not on 
the desktop. Users can select an item from the list instead of typing query criteria. If users do not 
want to search that field, they can select a blank line from the top of the drop-down list. 

Drop-down lists are appropriate for fields that contain short, unchanging lists. In addition, 
drop-down lists work best with lists whose items are limited to fewer than 50 or so characters 
each. This is because a drop-down list uses the box width specified in the Query Designer, so 
longer terms may get cut off. Avoid using drop-down lists for lengthy fields—use a Word Wheel 
instead. 

 

Users can open the 
drop-down list to see 
(and search for) actual 
indexed information. 
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A drop-down list shows entries from the Term index. If there is no Term index, the drop-down 
list shows entries from the Word index. If a box searches multiple fields, the drop-down list 
shows entries only from the first field in the box. (To re-order fields, select a query box, choose 
Tools>Box Properties>Fields and use the Change Order buttons.) 

To add a choices drop-down list 
1. Choose Search>Design Query Screen and open a query screen in the Query Screen 

Designer. 

2. Select the query box to which you want to add a choices drop-down list. 

3. Choose Tools>Box Properties to open the Query Box Properties dialog box. 

4. On the HTML tab, select the Add choices drop-down list option button. To limit the 
number of entries that will appear, select the Specify number of entries check box, then 
type the maximum number of entries you will allow. For example, if you type 15, only the 
first 15 entries will appear in the list. 

Note: The default and maximum number of terms that can appear is 200. 

5. Click Apply, then Close. 

6. Save the query screen, then export it to HTML (see page 50 if you need help doing this). 
When you export the query screen to HTML, a drop-down list will be generated as a static 
list and saved as part of the HTML page. If the textbase changes after the query screen is 
exported, you should re-export the query screen to update the list, or manually edit the 
HTML file. 

Adding a Password Box to a Query Screen 
When you design a query screen for Web use, you can add a password box to the screen so users 
can enter a password. 

Passwords entered into a query screen are carried through to the edit screens used, if your users 
are editing over the Web. 

To add a password box to a query screen 
1. In the Query Screen Designer, add a query box (choose Edit>Add>Query Box) to the 

query screen you plan to use on the Web. 

2. On the Query Box Properties dialog box, select the Labels tab and do the following: 

a. In the Label box, enter the label you want to appear on the box. For example, type 
Enter Password. 

b. From the Label position drop-down list, select an option to specify where the label 
appears (for example, Left or Top left.) 

3. On the HTML tab, select the Password option button. 

4. Click Apply, then Close. 
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Text Boxes 
When designing a query screen for Web use, you can specify that the text in a text box be 
interpreted in a particular way (for example, as Raw HTML or as a URL). 

To do this, use the HTML tab on the Text Box Properties dialog box (choose Tools>Box 
Properties) to select an option from the Treat text as drop-down list. 

 
The options in this drop-down list are also applicable to forms (and are selected from the Treat 
content item as drop-down list on the Form Box Properties dialog box). 

For an explanation of the options you can apply, see the Inmagic DB/TextWorks User’s Manual, 
or click the Help button on the dialog box. 

Note, however, that for a text box, the option is applied to the text you type in the Text box on 
the Text tab of the Text Box Properties dialog box.  
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Adding Multiple Textbase Searching Options to a Query Screen 
Note: This section does not apply to WebPublisher PRO Lite because that product only allows 
users to search a single textbase. 

You can design a query screen so users can search more than one textbase from it. Typically, the 
textbases being searched are similar in structure, with similar fields. 

Searching multiple textbases from a single query screen is helpful when users are searching for 
information that is kept in different textbases. For example, you may have product sales 
information in separate textbases for each year. Creating a query screen to search multiple 
textbases will let users search the data from all years (or whatever years you specify) from a 
single query screen. 

Note: You cannot use the WebPublisher PRO editing over the Web feature when searching 
multiple textbases. 

If you want to search more than one textbase with a single query screen, use the options on the 
WebPublisher Multiple Textbase Query dialog box (choose Tools>WebPublisher Multiple 
Textbase Query).  

• 

• 

• 

• 

Lead Textbase for WebPublisher Multiple Textbase Query. Select this check box to 
specify the textbase you have open as the lead textbase for searching multiple textbases on 
the Web. 

Textbases to Search. Click the Add button to specify additional textbases you want to 
search simultaneously with the lead textbase. The names of the additional textbases you 
select appear in the Textbases to Search list. 

Initial Report Form/Initial Display Form. Click these buttons to specify the report form 
and/or display form to be used by the Web browser to display records for the textbase 
selected in the Textbases to Search list. 

Create Field Name Map. Click this button to map fields in the lead textbase to fields in the 
textbase selected in the Textbases to Search list for the purpose of multiple textbase 
searching. 

To set up a WebPublisher PRO query screen to search multiple textbases 
1. Open the textbase that you want to specify as the lead textbase. 

Note: The textbase chosen as the lead textbase is the one with the records you want to 
appear first in reports (for example, the local book catalog before branch library book 
catalogs). It may also have secondary fields you want to search, or be the textbase with the 
index you want displayed in a Word Wheel. A Word Wheel can only be used to show the 
index for the lead textbase. 

2. In the Query Screen Designer, open the query screen from which you want to search 
multiple textbases. You can use an existing WebPublisher PRO query screen, or design a 
new one. 
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3. Choose Tools>WebPublisher Multiple Textbase Query to open the WebPublisher 
Multiple Textbase Query dialog box. 

4. Select the Lead Textbase for WebPublisher Multiple Textbase Query check box. This 
specifies the textbase you have open as the lead textbase. 

5. Click Add to open the Open Inmagic DB/TextWorks Textbase dialog box and specify the 
textbase you want to search simultaneously from the query screen. Click Open. The 
textbase will appear in the Textbases to Search list in the WebPublisher Multiple Textbase 
Query dialog box. Do this for each additional textbase you want to search simultaneously 
from the query screen. 

Important! If you plan to have users search multiple textbases from a query screen, you 
must make sure the paths of all the textbases to be searched are in the DBTWPUB.INI file. 

6. Select a textbase in the Textbases to Search list and click the Create Field Name Map 
button to open the Create Field Name Map dialog box. 

7. Specify which fields will be searched in each textbase when a user submits a query by 
selecting a field from the Lead Textbase Fields in this Screen list and then a corresponding 
field from the Fields Available in this Textbase list. 

Note: The fields in the Fields Available in this Textbase list are always from the textbase 
selected in the Textbases to Search list in the WebPublisher Multiple Textbase Query dialog 
box. 

8. Click the Create Map Between these Selected Fields button and the two fields appear in 
the Mapped Fields list. This means that when a user searches the field shown from the lead 
textbase, the field shown from the other textbase will also be searched. 

9. Repeat steps 7 and 8 for each field you want to map between the lead textbase and the 
textbase selected in the Textbases to Search list. Click OK when done. Notice that a 
message telling you how many fields are mapped appears next to the Create Field Name 
Map button on the WebPublisher Multiple Textbase Query dialog box. 

Note: Unmapped fields will automatically be mapped to the corresponding field in the 
search textbase. The corresponding field is the field that is in the same place structurally as 
the unmapped field (for example, if the first field in the lead textbase is unmapped, it will be 
mapped to the first field in the search textbase). 
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10. [Optional] To remove fields that have been mapped, select them in the Mapped Fields list, 
then click the Delete Entry button. Use the Clear All Entries button to remove all 
mappings from the Mapped Fields list. 

11. Use the Initial Report Form and Initial Display Form buttons to specify the default forms 
used when results are displayed from the textbase selected in the Textbases to Search list. 
Notice that the name of the form appears next to the applicable button. 

Note: The initial forms for the lead textbase are specified in the query screen (choose 
Tools>Screen Properties>HTML). 

12. Repeat steps 6–11 for each textbase in the Textbases to Search list. 

13. Click OK. 

14. Save the query screen and export it to HTML, as explained on page 50. 

Important! When saving a query screen that will search multiple textbases, you must select 
the Textbase File (Public) option button for it to be used on the Web. 

How multiple textbase query results are displayed 
When a user searches with a query screen designed to search multiple textbases, they use it the 
same way as one designed to search a single textbase. 

Records retrieved from the lead textbase appear first, in the report and display forms specified in 
the query screen. 

Records from subsequent textbases searched appear next, in the order in which those textbases 
were added in the Textbases to Search list. Results from each of those textbases appear in the 
report and display forms specified on the WebPublisher Multiple Textbase Query dialog box for 
that textbase.  

Tip! If you want the results of a multiple-textbase search to appear uniform, design identical 
forms for each of the textbases being searched and specify them as the report and display forms.  

Consider using forms that show all fields applicable to your users, as users cannot change forms 
when using a multiple-textbase query. 
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Exporting Query Screens to HTML 
To use a query screen on the Web, you must export it to HTML. 

To export a query screen to HTML 
1. In the Query Screen Designer, open the query screen you designed for use on the Web. 

2. Choose Screen Operations>Export Query Screen to HTML. 

3. A message box appears asking if you want to use Cascading Style Sheets (CSS) to preserve 
formatting. Click Yes to preserve formatting (such as, box and label position); click No if 
you want WebPublisher PRO to use simple HTML to format the screen (for example, all 
boxes will appear left-justified). 

4. On the Save File As dialog box, name the file when prompted and click Save. 

5. Click OK to dismiss the completion message. 

Notes about Exporting Query Screens to HTML 
• 

• 

• 
• 

• 

Buttons labeled Submit Query and Reset, and a Help icon, are added automatically during 
the export. 
Sets boxes, script input boxes, and script buttons added in the Query Screen Designer are 
not exported. 
Tab Order specified in the Query Screen Designer is preserved during the export. 
You can put the resulting HTML page anywhere accessible to the HTTP server. Be sure to 
provide users with a way to access the page, for example by providing a link on your home 
page that jumps to the HTML search page. 
If you make changes to a query screen in the Query Screen Designer after it has been 
exported to HTML, you must re-export it for your changes to be seen on the Web. 
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Editing HTML Query Screens 
You can use standard HTML editing tools to enhance your search screens. After exporting a 
query screen to HTML in DB/TextWorks, open the file in the HTML editor of your choice and 

add the features you want, such as check boxes and option buttons. You probably should keep 
related buttons, inputs, and applets near each other on the page so as not to confuse the user. As 
with any HTML form, be sure to test it thoroughly before putting it up on the Web. 

Important! If you re-export an edited query screen to HTML using DB/TextWorks, any 
changes made outside of DB/TextWorks will be lost. 

The following illustration shows a search screen called CARSXTRA.HTM, which is included 
with WebPublisher PRO in the SAMPLE subdirectory. You can open this page in your Web 
browser and view the document source. With a little practice, you can achieve similar effects for 
your own search screens. 
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Chapter 6: Designing Menu Screens for Web Use 

You design menu screens for use with WebPublisher PRO the same way you design menu 
screens for DB/TextWorks—using the Menu Screen Designer. 

However, menu screens used on the Web are quite a bit different from those used on the 
desktop. Each menu screen for the Web contains at least one textbase box with an “initial 
action,” which is a predefined search.  

A Web menu screen is essentially a list of predefined queries that appear as hypertext links. 
Users click the links to submit a query to WebPublisher PRO—without having to enter search 
criteria in a query screen. 

For example, the following Web menu screen includes three predefined queries for commonly 
requested information. 

 

Clicking a link 
runs a 
predefined 
query. 

Menu screens are especially useful when you do not want users to have to specify query criteria, 
and when many users are likely to want to perform the same searches. 

Tip! It is especially useful to use saved queries including @DATE as the initial action. For 
example, you could have an initial action (query) called Upcoming Events. The query 
criteria for this action could be @DATE : @DATE+14. This query would return all event 
records from the date of the query through the next two weeks. 

Before you begin designing a menu screen for the Web, be sure to create one or more sets that 
you will associate with items on the menu screen.  
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To do this, start DB/TextWorks, open a textbase, and perform a query. After retrieving records, 
choose Sets>Save Set. When prompted, name the set and save it in the Textbase File (Public). 
The search criteria will automatically be saved as a saved query. Repeat this step for each search 
that you include on the menu screen. 

When the menu page is displayed in a browser, the searches look like regular links. When a user 
clicks a link, WebPublisher PRO performs a query and displays records in the browser. From the 
user’s point of view, a regular hypertext jump has occurred. It is not immediately evident to the 
user that a textbase has been queried. 

Important! When the link is clicked, WebPublisher PRO re-executes the query. 
WebPublisher PRO does not simply load the set. The set will include any omitted records and 
any new or changed records that now match the query criteria. 

Once designed in DB/TextWorks, a menu screen must be exported to HTML before it can be 
used on the Web. 

There are several HTML properties you can add to a menu screen that is used on the Web. 

HTML properties can apply not only to menu screens as a whole, but also to individual text 
boxes within menu screens. When you design menu screens for the Web, you can select 
Web-specific properties from the menu locations listed below.  

• 
• 
• 

Tools>Screen Properties>Logos 
Tools>Screen Properties>HTML 
Tools>Box Properties>HTML (for text boxes only) 

These properties only affect menu screens exported to HTML for use on the Web. They are 
ignored for menu screens used on the desktop. 

For details about designing menu screens in general (that is, adding menu screen boxes, 
background color, and so forth), see the Inmagic DB/TextWorks User’s Manual. 
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Adding Logos to a Menu Screen 
Use the Logos tab on the Menu Screen Properties dialog box (choose Tools>Screen 
Properties>Logos) to add images to the top and/or bottom of a menu screen. 

 
Type the image name in the Leading Logo and/or Trailing Logo box, or click the Browse 
button to navigate to it.  

For more information, click the Help button on the dialog box, or see the Inmagic 
DB/TextWorks User’s Manual. 

For information on image file locations, see “ ” on 
page 69 of this manual. 

Logo and Background Image File Locations
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Adding HTML Properties to a Menu Screen 
Use the HTML tab on the Menu Screen Properties dialog box (choose Tools>Screen 
Properties>HTML) to add HTML-related properties to a menu screen. 

You can specify a background image for the menu screen, whether form drop-down lists appear 
on the Web when the results of predefined queries are displayed, how many records to display 
per page, and the location of navigational controls (such as, the Next/Previous buttons). 

 
For details about these settings, see the Inmagic DB/TextWorks User’s Manual, or click the Help 
button on the dialog box. 
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Using HTML Properties in Text Boxes on a Menu Screen 
Use the HTML tab on the Text Box Properties dialog box (choose Tools>Box 
Properties>HTML) to specify how the text you enter in a text box on a menu screen will be 
interpreted. 

 
Select an option from the Treat text as drop-down list. These options are the same as for query 
screens and are detailed in the Inmagic DB/TextWorks User’s Manual. 
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Exporting Menu Screens to HTML 
To use a menu screen on the Web, you must export it to HTML. 

Before exporting, you should first specify default forms for each textbase box (choose 
Tools>Box Properties>Initial Elements) and whether form drop-down lists should appear on 
report, display, and/or edit pages (choose Tools>Screen Properties>HTML). 

To export a menu screen to HTML 
1. Close any textbase that may be open, then open the menu screen you want to export in the 

Menu Screen Designer (choose Menu Screens>Design). 

2. Choose Menu Operations>Export Menu Screen to HTML. 

3. Name the file and specify a location in which to save it, then click OK. You can save the 
HTML page anywhere accessible to the HTTP server. (If you prefer, you can save it locally, 
then copy it to the server at a later time.) 

Notes about exporting menu screens to HTML 
• 

• 

The only items that are exported are text boxes, picture boxes, and textbase boxes whose 
initial action is a Saved Query (choose Tools>Box Properties>Initial Action). The export 
process ignores any textbase box that does not have Saved Query specified as the initial 
action. Icons are also ignored. 
Text in a textbase box does not retain the font, font style, font size, and color attributes 
specified in DB/TextWorks. When exported to HTML, the software automatically formats 
text in textbase boxes to appear as a standard hypertext link. 

Editing HTML Menu Screens 
You can use standard HTML editing tools to enhance your menu screens. After exporting a 
menu screen to HTML in DB/TextWorks, open the file in the HTML editor of your choice and 
add the features you want. As with any HTML form, be sure to test it thoroughly before putting 
it up on the Web. 

Note: If you re-export an edited menu screen to HTML using DB/TextWorks, any changes made 
outside of DB/TextWorks will be lost. 
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Chapter 7: Using Images on the Web 

When publishing a textbase on the Internet or an intranet, you can display images in a record, as 
well as used fixed images (for example, your organization’s logo) on Web query screens, menu 
screens, and forms. There are two types of images that can be used on the Web. 

• 
• 

Fixed images. These images are used in forms, query screens, and menu screens. 
Record images. These images are used in forms only. 

All images, except for those being used in picture boxes, should be sized appropriately. For 
example, you may want to reduce the dimensions of some images used as logos. Very large 
images may work better as link targets. 

Displaying Fixed Images 
You can use fixed images in forms, query screens, and menu screens. They can appear not only 
in the body of the form or screen, but also at the top, bottom, and/or as the background of the 
form and/or screen. When displaying fixed images, keep in mind the purpose of the image and 
where you want to place it, as these considerations determine the type of fixed image you use. 

There are several types of fixed images: 

• 

• 

• 

Picture box image. Use a picture box (choose Edit>Add>Picture Box in any of the 
designers) to add an image in the body of a report or screen. Use a picture box if you want 
the ability to specify the image size using the Picture Box Properties dialog box, or if you 
want to place the image in the body of the page. 
Logo. Use a logo when you want to place an image file at the top and/or bottom of a form, 
query screen, or menu screen. Logos are placed above and below the controls added 
automatically by WebPublisher PRO (such as, the Next Record and Previous Record 
buttons). An image placed at the top of a form or screen is a leading logo; an image placed 
at the bottom is a trailing logo. The actual size of the image is used. To add a logo, open the 
appropriate designer and choose the Tools menu, the appropriate Properties command (for 
example, Form Properties), and select the Logos tab. Enter the name of the image file name 
(for example, COMPANY.JPG) for the leading and/or trailing logo, as appropriate. 
Background image. Use a background image when you want to specify an image file as the 
page background for a form, query screen, or menu screen. To specify a background image, 
open the appropriate designer, choose the Tools menu and then the appropriate Properties 
command (for example, Screen Properties), select the HTML tab, select the Use 
background image check box, then choose an image file name.  
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Displaying Record Images 
You can use record images in forms. When displaying record images, keep in mind that some 
fields contain multiple images, so it is important to choose the method that will display the 
number of images you want, in the correct format. Record images appear in the body of the 
record. 

There are several types of record images: 

• 

• 

Picture box image. Use a picture box when you only want to show the first image in a 
field, in a box by itself, or when you want the ability to specify the size of the image using 
the Picture Box Properties dialog box. Using a picture box for record images requires that 
the user have HTTP access to the image files. When specifying the name and location of the 
image you want to display, you cannot use the image filename shortcut (for example, 
image.001 (3)). 
Inline image. Use an inline image when you want to display all images in a field that 
contains multiple images, display images in the same box with other content (such as text), 
and/or display an image not contained in an Image field. Inline images can be called by a 
file reference or an HTTP reference. The actual size of the image is used. 
Note: When inline images are used, WebPublisher PRO uses simple HTML, not CSS 
(Cascading Style Sheets). 

• Image link. Use an image link when you want to display a link to the image, rather than the 
image itself. This is useful when the image is unusually large (for example, file size and/or 
dimensions). Images can be called by a file reference or an HTTP reference. The image will 
display at its actual size. 

 



Textbase Record Images 
A textbase may include fields that hold the names of image files. For example, a field called 
Schematics might contain the entry DIAGRAM1.JPG. 

Most Web browsers support only JPEG and GIF image formats. DB/TextWorks does not 
support GIF. If you reference GIF files in a textbase, you will not be able to view those images 
with DB/TextWorks unless you launch them in their native application. This is an issue only 
when sharing textbases between desktop users and Web users. 

You can access textbase record image files on an intranet the same way as you would on the 
Internet. However, you also have the option of accessing the images by means of a network file 
addressing protocol. The advantage of this approach is that both DB/TextWorks and 
WebPublisher PRO can access the images in a shared location, by using the same file access 
protocol. (Compare this to Internet access, where WebPublisher PRO uses HTTP and 
DB/TextWorks uses file access, so sharing image files is not always practical.) 

To use file references for textbase record images 
1. With a form open in the Form Designer, choose Edit>Add>Form Box to add a form box 

and open the Form Box Properties dialog box. 

2. On the Fields subtab of the Contents tab, select a field that contains image file names. 

Note: To ensure that everyone has access to the images, the UNC file name should be 
specified (for example, \\server\image\poe.jpg). 

3. On the HTML tab, select Inline image or Image link from the Treat content item as 
drop-down list. Selecting Inline image displays the image as part of the form; Image link 
creates a link to the image on the form. 
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4. Select the Use file:// reference for image check box. This tells WebPublisher PRO to do 
the following, depending on what you selected in the previous step. 

– For Inline images, the images are referred to using a file URL. Note that if you use 
Inline image on the Web, CSS is turned off by default. If this is not what you want, use 
a picture box instead. For more information about specifying CSS settings, see the 
DB/TextWorks online help. 

– For Image links, the entry in the field is converted to a file URL. 
Note: The “conversion” is done in the form. The textbase records are not modified. 

5. Click Apply, then Close. 

If you selected Inline image in the steps above, the entry: 

\\server\image\poe.jpg 

will be treated as: 

<img src="file://///server/image/poe.jpg"> 

If you selected Image link, it will be treated as: 
<a href="file://///server/image/poe.jpg">file://///server/image/poe.jpg</a> 

 Destination Link Text
 
Notice that the destination and link text show the file name. You can specify different link text, 
as explained in the next section. 

To specify alternate link text for Image links 
Use the following steps to specify alternate link text for Image links. Note that this implies that 
you have already selected Image link from the Treat content item as drop-down list on the 
Contents tab. 

1. In the Form Designer, select a form box and choose Tools>Box Properties to open the 
Form Box Properties dialog box. 

2. On the Contents tab, select the field containing image file names from the Contents list. 

3. Select the Use alternate link text check box, then specify the text to use as the link in the 
Text box. For example, type Show Image to generate this link: 

<a href="file://///server/vol/images/poe.jpg">Show Image</a> 

4. Click Apply, then Close. 

Note: If there are multiple entries in the field, the alternate link text will be the same for all the 
entries. For example, if you use Click here as the alternate link text and there are three 
entries in the field, the alternate link text for each entry will be Click here. 
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Chapter 8: For the Webmaster 

Information for Webmasters is consolidated in this section. Textbase designers are also strongly 
encouraged to read this section, because they will need to coordinate file locations and other 
issues with the Webmaster.  
Before you can use WebPublisher PRO, you must set up a virtual directory called DBTW-WPD 
on the HTTP server, as explained in the WebPublisher PRO installation notes. 

Publishing a WebPublisher PRO Textbase 
A WebPublisher PRO textbase is designed using WebPublisher PRO software running under 
Microsoft Windows. The information in that textbase can be made available to local or remote 
Internet or intranet users running browsers, through the use of WebPublisher PRO. 

Here is a list of the tasks involved in publishing a textbase on the Web: 

1. Install WebPublisher PRO on a server that meets the system requirements detailed in the 
WebPublisher PRO installation notes. 

2. Copy the textbase and its associated files to a directory that can be accessed by 
WebPublisher PRO using a file path. 

3. Users point their browsers at a static HTML search page created using DB/TextWorks. This 
page submits the query to WebPublisher PRO, which returns the results as a dynamically 
formatted HTML document to the user’s browser for display. 

Advanced users: If you have experience with XML and XSL, you can build your own Web 
interface using third-party tools (such as, Microsoft FrontPage) and have it submit the query 
to WebPublisher PRO. 

The two primary tasks involved in publishing a textbase are to store the files in appropriate 
locations and ensure that appropriate permissions are set for those locations. For details about 
the permissions needed, see the WebPublisher PRO installation notes. 

During installation, WebPublisher PRO creates a directory structure with default locations for 
the external files associated with a textbase. You can copy external files to the default 
directories, or to other directories on the same or a different file server, then use DBTWPUB.INI 
to tell WebPublisher PRO where to look. 
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There are two kinds of “addresses” that WebPublisher PRO uses when opening files. Sometimes 
it opens files using a file path. For example: 

C:\PROGRAM FILES\INMAGIC\WEBPUB\TEXTBASE\MYDIR 

At other times, WebPublisher PRO constructs a URL to pass to the browser, in which case it 
uses an HTTP-style address. For example: 

/DBTW-WPD/HELP/WEB_BEGIN.HTM 

The relationship between the two kinds of addresses is controlled by the file locations specified in 
DBTWPUB.INI and the mapping settings (also called virtual directories) used by your HTTP 
server software. To understand the relationship, see the WebPublisher PRO installation notes. 

Publishing a “Live” Textbase 
If you plan to maintain your textbase over the Web (that is, you or your users will be adding, 
editing, and/or deleting records from a browser), you must provide Web access to the “live” 
textbase. 

Note: If you do not intend to modify records in any way over the Web, you can maintain the 
textbase (for example, add records) in another (non-server) location from your desktop and copy 
it up to the server for Web access after changes are made. 

Publishing a “live” textbase not only enables the textbase to be modified, but ensures that the 
most current information possible is being retrieved (so DB/TextWorks and WebPublisher PRO 
are both accessing the same textbase). When publishing a “live” textbase, there are special 
considerations: 

• 

• 

WebPublisher PRO must have file access to the textbase where it resides on the server. 
(Note that this applies to all textbases, regardless of whether they are “live.”) 
Textbase record image files should be located in the same directory as the textbase, so both 
DB/TextWorks and WebPublisher PRO can access them. If they are not in the same 
directory, the full path name should be included in the Image field (for example, 
\\SERVER\VOL2\IMAGES\MOM.JPG). 

Important! If the image will be accessed using HTTP, WebPublisher PRO will strip off the 
path and use the location specified in DBTWPUB.INI. The path in the record must be 
correct for the aspect ratio to be preserved in picture boxes on forms. For more information 
about preserving the aspect ratio, see Chapter 5 of the Inmagic DB/TextWorks User’s 
Manual, the “Using picture boxes on the Web” section. 

• Internet applications can display only GIF or JPEG images in a browser without a special 
plug-in. DB/TextWorks can display JPEG and many other image formats, but not GIF. 
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Intranets 
You can use WebPublisher PRO on an intranet as well as on the Internet. An intranet is a local 
or wide-area network that operates in a manner similar to the Internet, using TCP/IP, browsers, 
and HTML pages. By publishing textbases on an intranet, you can make information widely 
available within your organization across a variety of platforms. For example, you can publish 
company policies and procedures and provide shared access to image files. 

 
Publishing textbases on an intranet is identical to publishing on the Internet, except that you can 
launch applications and access images using file:// references in addition to, or instead of, HTTP.  

Important! Be sure to check with the Webmaster before using network file access, to find out 
which protocol is preferred.  
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File Locations 
The following sections detail the locations of various files. 

Textbase File Locations 
A textbase consists of multiple files with the same name but different file extensions. For 
example, a textbase called Sales consists of SALES.ACF, SALES.BTX, SALES.DBR, 
SALES.DBO, SALES.DBS, SALES.IXL, SALES.OCC, SALES.SDO, SALES.TBA, and 
optionally, SALES.ACS (if the textbase uses record-level security), SALES.LOG, SALES.INI, 
and SALES.HLP files. Note that if you are editing over the Web, the textbase .INI file (for 
example, SALES.INI) is required, as it contains XML match field information. 

If the textbase designer indicates that any textbases are linked, it is recommended that you place 
the linked textbases in the same directory. If they are in the same directory, omit the path from 
the link. If they are in different directories, you must specify the path using a UNC file name. 

The DBTWPUB.INI file controls where WebPublisher PRO looks for textbases. When you 
installed WebPublisher PRO, you had the opportunity to specify one or more textbase search 
paths, which were written to the [WebPublisher Defaults] section of DBTWPUB.INI. 
You can also optionally indicate a specific location for each textbase by modifying the 
[WebPublisher Textbase Paths] section in DBTWPUB.INI manually. For example:  

[WebPublisher Defaults] 
Default-Textbase-Paths=c:\webpub\textbase\,c:\data,\\server2\tbs 

[WebPublisher Textbase Paths] 
cars=c:\webpub\sample\ 
catalog=c:\data\library\ 

If you installed the sample textbase (named Cars), this section is already present. Do not add the 
section again, but add the location to the existing one. (If you add another section, it will be 
ignored.) 

If you have only one textbase, or if you have multiple textbases of limited size without images, 
you may want to put them all in the same directory (for example, the TEXTBASE subdirectory). 
If you have several textbases with images that you want to keep separated, or you want to locate 
multiple textbases on different file servers, you will probably want to edit the DBTWPUB.INI 
file to specify file locations.  
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What happens when a user submits a query 
When a user submits a query, WebPublisher PRO looks for the textbase and, once found, 
ensures its location is retained for future reference. The following steps provide details as to 
what happens once a query is submitted. 

1. WebPublisher PRO checks the [WebPublisher Textbase Paths] section of 
DBTWPUB.INI for the textbase name and looks in the specified location. This occurs 
regardless of whether the user is submitting a query from an HTML query screen or is 
submitting XML. 

2. If the textbase name does not appear in that section or the textbase does not exist in the 
specified location, the software looks in the directories specified in the 
Default-Textbase-Paths parameter of the [WebPublisher Defaults] 
section. This occurs regardless of whether the user is submitting a query from an HTML 
query screen or is submitting XML. 

3. If it does not find it, the software acts differently depending on how the user sent the query: 

– If the query was submitted from an HTML query screen, WebPublisher PRO displays a 
message with a Search button. Clicking the button initiates a recursive subdirectory 
search on the directories listed in the Default-Textbase-Paths parameter of the 
[WebPublisher Defaults] section. 

Note: If the user is using a single HTML query screen to search multiple textbases, 
WebPublisher PRO will only do a recursive subdirectory search for the lead textbase. 
For the search textbases, if the textbase is not found in step 1 or 2, a message notifying 
the user that the textbase(s) cannot be found appears on the report page. 

– If the query was submitted in XML, a message is returned in the XML output notifying 
the application that the textbase cannot be found. 

4. If WebPublisher PRO finds the textbase in steps 2 or 3, it writes the location to the 
[WebPublisher Textbase Paths] section, so the search will not be necessary in 
the future. 

Important! The Internet user account (IUSR/IWAM) used by WebPublisher PRO must have 
read access to the directories in which textbases reside. For the textbase search feature to work, 
this account must also have write access to DBTWPUB.INI and read access to all directories 
specified in the Default-Textbase-Paths parameter of the [WebPublisher 
Defaults] section. 
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HTML Search and Edit Screen Locations 
Search, menu, and edit screens are HTML pages created with DB/TextWorks, which users will 
use to submit queries (search or menu screens) or add records (edit screens) to a textbase. You 
can place these screens anywhere accessible to the HTTP server. They do not have to go in any 
particular directory. Be sure to provide users with a way to access the pages (for example, 
provide links on your home page that jump to the HTML search pages).  

If you have upgraded from WebPublisher PRO version 1.0 to version 7.0, edit screens you 
exported to HTML in version 1.0 will continue to work. However, because version 7.0 provides 
better formatting on the Web, you may want to export each edit form to HTML again. If you do 
that, you can delete the copy of DBTWP-EDIT.ASP in the same directory as the exported 
HTML edit form. (Note that in WebPublisher PRO version 1.0, a copy of this .ASP file was 
required to be located in each directory containing an exported edit form. With 
WebPublisher PRO version 7.0, this is not necessary. Only one copy of this file is needed—an 
updated version [now named IWPP-EDIT.ASP] is installed in the ASP subdirectory of the 
WebPublisher PRO installation directory.) 

Image File Locations for Forms 
Use DBTWPUB.INI to specify the location of:  

• 

• 

Record images. Image file names specified in textbase records and included as picture 
boxes, inline images, or image links in a form. 
Fixed images. Logo and background images and picture boxes containing static images 
used in forms.  

You can specify an image location for each textbase or put images in a default location. 
WebPublisher PRO removes any path information specified for the image in the textbase record 
(unless you use an HTML file:// reference), then constructs a URL by prepending the text you 
specify.  

Note: If you use a picture box on a Web form with CSS, the file path is used to determine the 
size of the image in order to preserve the aspect ratio or prevent text from overlapping the image. 

Use the [WebPublisher Image Locations] section of DBTWPUB.INI to specify the 
text WebPublisher PRO should use to construct the URL for record images used in specific 
textbases. In the example below, vacation is the name of a textbase.  

Use the [WebPublisher Logo Locations] section to construct URLs for fixed images 
(for example, logos and backgrounds) used with specific textbases. In the example, vacation 
is the name of a textbase.  

In the [WebPublisher Defaults] section, use the Default-Logo-Location= and 
Default-Image-Location= lines to specify the text used to construct image URLs if the 
textbase name does not appear in either of the other sections.  
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Example:  

[WebPublisher Defaults] 
Default-Textbase-Paths=\\server2\tbs\,c:\webpub\textbase\ 
Default-Logo-Location=/mylogos/ 
Default-Image-Location=/myimages/ 

 
[WebPublisher Image Locations] 
vacation=/vacimage/ 

 
[WebPublisher Logo Locations] 
vacation=/mylogos/vac/  

Note: A logo or image location that starts with a forward slash (for example, /myimage) is 
relative to the HTTP server root. A location without a leading "http://host" or "/" is relative to 
the location of the query or menu screen that submits the query. 

For more information about DBTWPUB.INI, see the DB/TextWorks online help.. 

Logo and Background Image File Locations 
By default, WebPublisher PRO expects to find logo and background images for forms in the 
location specified in DBTWPUB.INI (see above). It expects to find logo and background images 
for query and menu screens in /DBTW-WPD/IMAGES (the HTTP equivalent to C:\PROGRAM 
FILES\INMAGIC\WEBPUB\IMAGES). To display the images, the software constructs a URL 
to send to the browser. For example: 

/dbtw-wpd/images/corplogo.gif 

The textbase designer can specify alternate locations using the Logos or HTML tab (choose 
Tools>Form Properties>Logos or Tools>Form Properties>HTML) in the Form Designer, 
Query Screen Designer, or Menu Screen Designer. To override the default location, the image 
file name must include a forward slash (/). Some examples: 

http://www.inmagic.com/logos/corplogo.gif 
/backgrnd/simple.gif 
pictures/me.gif 

A logo or image location that starts with a forward slash is relative to the server root. A location 
without a leading "http://host" or "/" is relative to the location of the query or menu screen that 
passed the query to WebPublisher PRO. 

Note: This functionality does not apply to textbase image names stored in records. The software 
strips all path information from image names stored in records and uses the Default-Image-
Location= and [WebPublisher Image Locations] settings in DBTWPUB.INI to 
specify their location. 
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Initialization Files 
WebPublisher PRO reads settings from three initialization files. All three files should reside in 
the directory in which WebPublisher PRO is installed.  

• 

• 

• 

DBTWPUB.INI. Textbase and image directory settings and other options specific to 
WebPublisher PRO. This file is required for WebPublisher PRO. 
INMAGIC.INI. User options shared with DB/TextWorks. This file is optional for 
WebPublisher PRO. 
DBTEXT.INI. Settings (primarily date formatting/indexing settings) shared with 
DB/TextWorks. This file is optional for WebPublisher PRO. 

The Internet user account should have Read-Write access to DBTWPUB.INI and Read access to 
INMAGIC.INI and DBTEXT.INI. Be sure that the Internet user account has Read access to any 
image or textbase directories you specify. If you plan to allow users to modify records over the 
Web, the textbase directory must have Full Control access. 

You can override many of the parameters set in the DBTWPUB.INI file by adding parameters to 
the exported HTML query screen or including parameters in any XML submitted to the 
application. 

For more information about theses .INI files, see the DB/TextWorks online help. 
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Testing your Textbases: A Checklist 
Before you make your textbases widely available on the Internet or an intranet, test them from a 
remote computer running a browser (not from the server itself) to be sure that everything works 
the way you intended. If your end users are likely to be using a variety of browsers, test with a 
representative sample of them. The best way to test is to run through a sample search, retrieval, 
and display. If your application supports editing the textbase, you should also test this feature. 
Use the following list as a checklist of the major areas to test. 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

Have you handed off all the necessary files to the Webmaster and coordinated issues about 
initialization files and textbase and image locations? For more information, see “

,” on page 66 and “ ” on page 70. 
File 

Locations Initialization Files
Do all your search screens appear as you intended? Try several queries to see if you retrieve 
the intended records. 
Do Word Wheels appear correctly on the screen? Do they work as expected? Try pasting a 
few entries into various query boxes. 
Do all images appear correctly? Check logos, backgrounds, and textbase record images on 
forms, query screens and menu screens. 
Do all links go to the correct destinations? Verify that there is a link on your Web site that 
takes you to the search screen. Check all links on query screens, menu screens, and reports. 
Does every report include an expand record link, if appropriate? Is the link text available for 
every record? 
Do all your reports look the way you intended? Try several different searches, to obtain 
different record sets. Select each report form and display form in the browser. Different 
record sets, such as records that lack information in a field, may affect appearance. 
If your Web query screen was designed to search multiple textbases, try a search that should 
retrieve records in all of the textbases. Try using each query box and click on any “See 
Also” search links to verify that you have mapped all the necessary fields. 
If you changed message or button text by creating and connecting a MYMSG.INI file, 
verify that your modifications appear when and where you expect them. For more 
information about creating a MYMSG.INI file, see the DB/TextWorks online help.

If you have specified that expanded records open in a separate browser window and/or you 
specified that a New Search button appears on screens, verify that they work as you 
intended. Note that these features are specified by adding parameters to the DBTWPUB.INI 
file. 
If your textbase has Link fields, verify that you can search for and display information from 
secondary textbases. 
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• 

• 

• 

• 

• 

If your textbase has passwords, verify that the query screen (or edit screen) includes a 
password box. If the textbase has a Silent password, verify that it hides the fields or records 
you expect it to hide. 
If you included New record, Edit record, and/or Delete record links on your forms and 
screens, verify that they open the appropriate edit screen and that you can modify records as 
you intended. 
If you included any validation list links on edit pages, test them to be sure they open the 
Inmagic Choices Browser window. 
If you made changes to the supplied help pages (WEB_*.HTM), click the Help button on 
the query screen, in the Word Wheel dialog box, on and Inmagic Choices Browser window 
to be sure you access the changed help pages. If you renamed the pages, test the inter-page 
jumps. For example, WEB_BEGIN.HTM includes links to WEB_WW.HTM and 
WEB_MSG.HTM. 
Consider doing a usability test to be sure that your search screens and forms are clear and 
intuitive. Try having an uninitiated user go to your home page and see if that person can 
figure out what to do: how to jump to a search screen, which fields to query, what to search 
for, and what syntax to use. 
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Chapter 9: Tutorial 

You can practice publishing textbases on the Web by performing the following tutorial. The 
exercises are based on a fictitious organization called The Model Company, which sells high-end 
model cars. The company uses a textbase called Cars, which it publishes on the Internet.  

The Cars textbase is included with WebPublisher PRO and can be installed by running Setup. 
The Cars textbase and associated files are installed in the SAMPLE subdirectory. 

This tutorial assumes you are using a “live” textbase, which means DB/TextWorks and 
WebPublisher PRO are accessing the same copy of the textbase. 

If this is not possible in your configuration, copy the sample textbase (CARS.*) to a machine that 
DB/TextWorks can access. After each exercise in which you use DB/TextWorks to make 
changes, copy the textbase files or HTML pages back to the HTTP server so WebPublisher PRO 
can access them. However, if you go this route, you will be able to edit records over the Web 
and use validation list links, but when you copy the DB/TextWorks textbase over, you will lose 
the changes you have made to the records using WebPublisher PRO. 
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Exercise #1: Searching on the Web 
In this first exercise, you will go to a Web page that was created with DB/TextWorks and do a 
search. The records that you find will be displayed in your browser. 

Searching for Records and Displaying a Report 
1. Point your Web browser to http://hostname/dbtw-wpd/sample/carsqs.htm, 

where hostname is your domain name or IP address. The search screen opens. This page 
was created with DB/TextWorks. Each box represents a field that you can search. 

2. To find all models that come as kits (not assembled) and cost less than $200, type Kit in 
the Model Type box and < 200 in the Price box. 
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3. Click the Submit Query button. WebPublisher PRO searches the textbase, finds the 
records that were requested, and displays them in the browser as a formatted HTML page. 

 

Use this drop-down 
list to change forms. 
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4. To see a different view of the records, select Pictures & Prices from the drop-down list at 
the top or bottom of the page. WebPublisher PRO reformats the information using a form 
stored in the textbase. 
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Displaying a Single Record 
The reports you have seen have been summaries of the records found. You can easily “drill 
down” to get detailed information about individual records. 

To view individual records 
1. Scroll to any record in the report and click the link text (the name of the car) to see detailed 

information about that record. When you click the link text, WebPublisher PRO displays 
that single record using the display form specified in the query screen. 

 
2. Click the Next Record and Previous Record buttons to see other records, one at a time. 

3. Select a different form from the drop-down list at the top of the page to change how the 
record appears. This formatting is done dynamically. WebPublisher PRO gets the form 
stored in the textbase, applies it, and sends the formatted page back to the browser. 
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Exercise #2: Using the Buildware 
DB/TextWorks is the buildware—the software that you use to create the textbases, forms, and 
search screens that you publish on the Web. In the previous exercise, you searched a textbase 
and displayed the results in your browser. Now you will see how to create search screens (query 
screens) and forms (including an edit form) for Web use. You will edit a records in the Cars 
textbase from your browser, as well as learn how to batch modify records on the desktop. 

Getting Help 
If you have any questions while you are using DB/TextWorks, use the DB/TextWorks online 
help. 

For help on a particular window, click the Help on this Window  button. 

For help on a particular toolbar button or menu command, click the Context Help button  
then click the toolbar button in question, or open a menu and click on a command. 

Designing Forms 
Forms determine the appearance of information retrieved from a textbase. 

Forms can show or hide fields, add text and punctuation, control layout and colors, and include 
variables and calculations appropriate for complex computations. You can also use an edit form 
on the Web to add, edit, and/or delete records. 

To design a Web edit form 
In the following steps, you will design a Web edit form, which will be used later to edit a record 
in the Cars textbase from a Web browser. 

1. If you have not already done so, start DB/TextWorks. 

2. Choose File>Open and select the Cars textbase, which is located by default in the 
WebPublisher PRO SAMPLE subdirectory (for example, C:\PROGRAM 
FILES\INMAGIC\WEBPUB\SAMPLE\CARS). 

3. Choose Display>Design Form to open the Open Form dialog box. 

4. From the Start With list, select Basic Form, then click OK. The Basic form, which contains 
one box for each field in the textbase, opens in the Form Designer. 

5. Use the Form Designer to design the edit form to suit your needs. Change the box labels, 
add a title for the edit form, add background color, and apply any other design settings you 
want. 
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6. Choose Form Operations>Save Form to open the Save Form As dialog box and do the 
following: 

– In the Name box, enter a name for the form. For this exercise, type Edit Screen. 
– [Optional] In the Description box, enter description of the form (for example, type Web 

editing form for Cars textbase). 
– In the Save In group, select the Textbase File (Public) option button. 
– In the Use For group, select the Edit Window and Web check boxes and clear any 

others that may be selected. 
– Click OK. 

To edit an existing form 
In this exercise, you will add an Edit record link to the Prices form that you originally saw on the 
Web. This link will open an edit screen so you can modify records. 

1. In the Form Designer, choose Form Operations>Open Form to open the Open Form 
dialog box. 

2. From the Currently Saved list, select the existing form called Prices, then click OK. 

3. Change the sort order by choosing Report Options>Compulsory Sort to open the Specify 
Compulsory Sort Order dialog box and do the following: 

a. Remove Name from the Sort Fields list by clicking the left arrow button. 
b. Add Club Price to the Sort Fields list by selecting it in the Available Fields list and 

clicking the right arrow button. 
c. Click OK. 

4. Add an Edit record link to the form: 

a. Select the Status box, then choose Edit>Add>Text Box. The Text Box Properties 
dialog box opens. 

b. On the Text tab, type Edit Record in the Text box. 
c. On the HTML tab, select Edit record link from the Treat text as drop-down list. 
d. Click Apply, then Close. 

5. Choose Form Operations>Save Form to save the form. 

6. Choose Form Operations>Close Form Designer to close the Form Designer. 

Note: If you are not sharing a “live” textbase, copy the textbase files (CARS.*) from the 
local machine to the SAMPLE subdirectory on the server now. 
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Designing Query Screens 
To enable Web users to search a textbase, supply one or more query screens in HTML format. A 
query screen contains boxes in which users type search criteria. Each box searches one or more 
fields. 

To design a query screen 
In the following steps, you will add Word Wheel and Boolean buttons to a query screen, export 
it to HTML, and then do a search using the new query screen. You will also view records using 
the Prices form you modified and the new Edit Screen form. 

1. Make sure the Cars textbase is still open from the last exercise. 

2. Choose Search>Design Query Screen to open the Open Query Screen dialog box. 

3. Select Catalog QS-HTML from the Currently Saved list. This is an existing query screen 
saved in the textbase. Click OK. 

4. Add a query box by choosing Edit>Add>Query Box, or by clicking the Add Query Box 

button  on the Query Screen Designer toolbar. The Query Box Properties dialog box 
opens. 

5. On the Fields tab, select Features from the Fields list and click the Add button. 

6. On the HTML tab, select the Add Word Wheel option button to add a Word Wheel to the 
screen. 

7. Click Apply, then Close. The Word Wheel button will not appear until you view your page 
in a Web browser. 

8. Choose Tools>Screen Properties to open the Screen Properties dialog box. 

9. On the HTML tab, select the Show Boolean operators check box to add a Boolean 
drop-down list (AND, OR, NOT) to all query boxes on the page. 

10. Click OK. The Boolean drop-down lists will not appear until you view the page in a Web 
browser. 

11. Choose Screen Operations>Export Query Screen to HTML to export the query screen to 
HTML. 

12. A message appears asking if you want to use Cascading Style Sheets to format the query 
screen. Click Yes. 

13. When prompted, name the file CARSQS2.HTM and save it in the SAMPLE subdirectory of 
the WebPublisher PRO installation directory. Click OK on the confirmation message. 

Note: If you cannot save it directly onto your Web site, save it anywhere; then copy the 
HTML file to the server later. 

80 Chapter 9: Tutorial 



14. Choose Screen Operations>Close Query Screen Designer and answer No when asked if 
you want to save the query screen. 

Note: If you want to save the query screen under a different name, select Cancel when 
asked if you want to save the query screen, then choose Screen Operations>Save Query 
Screen As and choose a new name for it. 

15. Point your Web browser to CARSQS2.HTM. For example, point to 
http://hostname/dbtw-wpd/sample/carsqs2.htm, where hostname is your 
domain name or IP address. 

 
16. View the changes you made to the query screen: 

– A box labeled Features so users can search by feature. 
– A Boolean drop-down list on each box so users can choose from AND, OR, and NOT 

to combine search criteria among multiple fields. 
– A Word Wheel button, so users can look at indexed information from the Features field 

in the textbase. 
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17. Submit a query and view the changes you made to the Prices form. 

– Records are sorted by price instead of name. 
– A new column containing an Edit record link. 

18. Edit a record by clicking the Edit Record hypertext link in the last column of its row. The 
record opens in the initial edit form specified in the query screen. (This form was predefined 
in the Cars textbase for you. For more information about how to specify initial forms, see 
“ ” on page 41.) Adding HTML Properties to a Query Screen

19. Select Edit Screen from the form drop-down list on the page to change the edit form to the 
one you designed earlier in this tutorial. 

20. Edit the record. For example, click any box label that is a hypertext link to open the Inmagic 
Choices Browser window. You can paste an entry from the field’s validation list. 

21. Click the Submit Record button to save the changes, then click OK in the confirmation 
window. 

22. Click the Rewind button (<<) to return to the query screen, then search for the record you 
modified to see the changes. 

Batch Modifying Records on the Desktop 
Information on a Web site is subject to change. To keep information current, DB/TextWorks 
offers many powerful editing features, including the ability to batch modify records. 

To batch modify records on the desktop 
In the following steps, you will use the batch modify feature on the desktop to make the same 
change to several records at once. 

1. If you have not already done so, start DB/TextWorks and open the Cars textbase. 

2. In the Name of car box, type porsche / winger / supra and press Enter. This 
searches the Name field for Porsche OR Winger OR Supra. 

3. On the Select Search Results Window dialog box, select Report window, if it is not already 
selected. Click OK, and the records matching the criteria display. 

4. Choose Records>Batch Modify to open the Batch Modify Records in Set dialog box. 

5. Select Features from the Field to Modify list, Append Entry After from the Operation 
choices, and Last Entry from the Affects choices. These settings tell the software to modify 
the information in the Features field by appending the new entry (which you will specify in 
the next step) after the last entry in the field. 

6. Type Glass windshield in the New Entry box. Click OK. 

7. On the Content Validation Mismatch dialog box, click Accept & Update List. 
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8. Click Yes in response to the confirmation message, then OK on the completion message. 

Note: If you are not sharing a “live” textbase, close the textbase; then copy the textbase files 
(CARS.*) from the local machine to the SAMPLE subdirectory on the server. 

9. View the change on the Web by pointing your browser to either CARSQS.HTM or 
CARSQS2.HTM. 

10. Type porsche / winger / supra in the Name of car box and click Submit Query. 
The matching records display. 

11. Select Pictures & Prices from the form drop-down list and notice that the new feature, 
Glass windshield, is listed. 

Now that you have a basic understanding of how to publish textbases on the Web, try creating 
some textbases of your own, following the instructions provided in the Inmagic DB/TextWorks 
User’s Manual. 
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Appendix: Troubleshooting  

This appendix can help you solve some common problems. For a complete list of 
WebPublisher PRO error messages, see the WEB_MSG.HTM. file. 

Message: DB/Text WebPublisher could not find textbase '<name>' on the server. 
There are several possibilities. The textbase might not be located in any of the directory trees 
specified in the Default-Textbase-Paths= parameter in DBTWPUB.INI. You can open 
DBTWPUB.INI in a text editor and add the textbase location to the [WebPublisher 
Textbase Paths] section.  

If the textbase resides on a different drive than the HTTP server, use the UNC directory name 
(for example, \\SERVER\VOL2\DIRECTORY), rather than the drive letter (for example, 
C:\DIRECTORY) in the [WebPublisher Textbase Paths] section and/or the 
Default-Textbase-Paths= parameter in DBTWPUB.INI. 

The Internet user account (for example, IUSR_SERVERNAME) submitting the query must have 
Read access to the directory where the textbase resides. (Note that if you plan to allow users to 
modify records over the Web, the textbase directory must have Full Control access.) 

Long file names with spaces can cause problems with some HTTP servers. Use short file names 
(eight characters) for compatibility. 

Message: The textbase '<tbname>' has not yet been located on the server. 
The textbase location has not been specified in the [WebPublisher Textbase Paths] 
section of the DBTWPUB.INI file or WebPublisher PRO cannot find the textbase in the 
specified location. Click the Search button on the page to have WebPublisher PRO do a 
recursive subdirectory search for the textbase in the locations specified in the 
Default-Textbase-Paths= parameter in DBTWPUB.INI. 

Message: DB/Text WebPublisher found textbase '<name>' - you may re-execute 
your query (press Back twice). 
WebPublisher PRO successfully found the textbase and wrote its location to the 
[WebPublisher Textbase Paths] section of the DBTWPUB.INI file. If you press the 
Back button twice and perform the query again and get the message “The textbase ‘<tbname>’ 
has not yet been located on the server,” the Internet user account does not have Write access to 
DBTWPUB.INI. You need to either provide Write access or edit DBTWPUB.INI and add the 
textbase location. 
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Message: Your current query has expired. Perform the search again. 
This error indicates that the slot occupied by a query set has been re-used by someone else’s 
query. Too much time may have passed since the query was first performed, or too many users 
may be searching the textbase simultaneously. To increase the maximum number of query sets 
that can be stored, open DBTWPUB.INI, which is located in the WebPublisher PRO installation 
directory. Edit the WebSetMax parameter in the [WebPublisher] section. The default value 
is 2000, which is usually sufficient. If it is already at 2000 and you are still getting this error, 
increase the value. 

[WebPublisher] 
WebSetMax=2000 

Symptom: Multiple JavaScript errors when loading a query or menu screen in a 
Web browser. 
Make sure that the /DBTW-WPD virtual directory has been mapped (aliased) to the 
WebPublisher PRO installation directory and has the necessary access (Read, Execute, and 
Scripts).  

Symptom: I found records, but I get an error when I try to change the form, 
display more records, or click link text on the report. 
Verify that WebPublisher PRO has Full access to the query set files (<textbase>.WPD and 
<textbase>.WPO) and the subdirectory where they reside (QSETS). 

Symptom: When I submit a query, I do not find the intended records. 
If you are doing a Boolean or range search (&, /, !, :), the problem may be related to the 
SpacedRelOps= setting. Interpretation of search symbols is controlled by the 
SpacedRelOps= setting in the [Inmagic DB/TextWorks] section of the INMAGIC.INI 
file, located in the WebPublisher PRO installation directory. If SpacedRelOps=0, spaces are 
not required around search symbols. They are always treated as Boolean operators unless 
embedded within a quoted phrase. If SpacedRelOps=1, spaces are required around search 
symbols. They are treated as search symbols only if surrounded by spaces. The advantage of 
SpacedRelOps=1 is that users can search for dates such as 12/31/98 or URLs such as 
http://www.inmagic.com without having to use surrounding quotes. 

Other possibilities are that the field is protected by a password, the query syntax is wrong, or 
Boolean operators are being misunderstood. The textbase designer can help users by adding 
instructions or examples to the query screen, supplying drop-down lists for fields with limited 
variations, omitting Boolean buttons if the target audience is likely to be confused, and/or 
supplying both simple and advanced search screens. 

86 Appendix: Troubleshooting 



Symptom: The Word Wheel buttons do not appear in my browser. 
Nothing happens when I click a Word Wheel button in my browser. 
The Word Wheel requires Microsoft Internet Explorer version 3.0 or later, or Netscape 
Navigator version 3.x/4.x. For recent versions of Internet Explorer, you must install and use the 
Microsoft Virtual Machine. Recent versions of Sun Java are not backwards-compatible and do 
not function with Word Wheels, and recent versions of Netscape Navigator use this incompatible 
version of Sun Java. 

Symptom: The Word Wheel dialog box is empty. 
The first field searched by the box may be empty. Try selecting a different field from the Field 
drop-down list on the Word Wheel dialog box. 

Other possibilities are that the textbase may be missing, inaccessible, or damaged; that your Web 
browser does not support Java and needs to be upgraded to a newer version that does; that Java 
is disabled in your browser settings and you need to refer to your browser’s online help to learn 
how to enable it; or that you are using Netscape and your textbase name contains spaces. 

To verify that the problem is with the Word Wheel itself (and not with the search screen or 
textbase), do a simple search in the same query box. If the search does not work, then the 
problem is not specifically with the Word Wheel. 

Symptom: Some forms do not appear in the Web browser drop-down list. 
Did you choose the correct properties when saving forms? For each form that you will use on the 
Web, choose Save Form As in the Form Designer, then save the form in the Textbase File 
(Public). You must also select the Web check box. Also, select either the Report Window (for 
multiple-record display) or Display Window (for single-record display) or Edit Window (for 
editing over the Web) check boxes. 

Symptom: Records displayed after a search look “awful” in my browser. 
If a Web browser does not support tables, then tabular forms used to display search results will 
not appear properly. To display tables properly, use version 3.0 or later of Microsoft Internet 
Explorer or Netscape Navigator (version 4.0 or later preferred). If you cannot upgrade your 
browser, use DB/TextWorks to create non-tabular report forms. 
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Symptom: Records displayed after a search do not look like they did in 
DB/TextWorks. 
The form may contain Raw HTML or inline images, or you have WebCSSOpt=0 in 
DBTWPUB.INI. 

Symptom: Records displayed after a search are printing on top of each other 
(overprinting). 
The form may be using a font size greater than 10 point. Change the font size to 10 point or set 
WebCSSOpt=0 in DBTWPUB.INI. Another cause could be that the form contains Raw HTML 
or inline images and you have WebCSSOpt=2 in DBTWPUB.INI. Adjust the form to better 
position the box containing the Raw HTML. 

 

88 Appendix: Troubleshooting 



Glossary  

Access Control field  
A field type that provides record-level security by letting you restrict access to classes of 
records. The record class is specified by the content of this field. See also record-level 
security. 

alternate link text 
Text that appears on a Web page, acting as a link to an image, URL, file, and so forth. 

API 
Application Programming Interface. See also ISAPI. 

Back (<) button 
A button automatically added to screens and forms used on the Web that returns you to the 
previous screen. 

background image  
Image file specified as the page background for a form, query screen, or menu screen used 
on the Web.  

Basic form 
Simple form, generated by the software, containing a box for each field in the primary 
textbase. Fields appear in the order in which they are defined in the textbase structure. The 
Basic form is often useful as a starting point in the Form Designer. 

Basic Query Screen 
Simple search screen, generated by the software, containing a box for each indexed field in 
the primary textbase. The Basic query screen is often useful as a starting point in the Query 
Screen Designer. 

batch modification 
Process by which multiple records are changed in the same way, by the addition, deletion, 
or modification of a field or field entry, or substitution of text. 

Boolean commands 
Commands (AND, OR, NOT) used to combine search expressions in order to produce a 
desired result. 
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Boolean drop-down lists 
Drop-down lists associated with searchable boxes on a Web query screen, allowing the 
Boolean command associated with that box (AND, OR, NOT) to be changed by the person 
performing the query. 

Boolean operators 
Symbols (& / !) used to combine search terms: & represents AND, / represents OR, ! 
represents NOT.  

borders 
Lines drawn around the four sides of a box. When designing a form or query screen, you 
can choose whether or not to show the borders for any specified box when the form or 
screen is used. 

boundaries 
Dashed lines that you can choose to see while designing a form, query screen, or menu 
screen indicating the location and dimensions of each box. It is especially useful to turn on 
boundaries (check Boundaries on the View menu) if the boxes on the form do not have 
visible borders. Boundaries are a design tool only. They do not appear in the saved form or 
screen. See also entry boundary. 

browse 
To peruse a list of terms that you can paste while searching or editing records. 

browser 
A program used to view material prepared for the Web. Browsers can interpret URLs and 
HTML, and can understand several Internet protocols, such as HTTP, FTP, and Gopher. 
Examples of browsers are Microsoft Internet Explorer and Netscape Navigator. 

Cascading Style Sheet 
A Web page (for example, WEBSTYLE.CSS) that you create to define styles (for example, 
fonts, colors, spacing) for your Web documents (for example, HELP.HTM). Having a 
cascading style sheet (CSS) gives the Web page creator more control over the appearance 
of a Web page (rather than to the Web browser). Netscape and Internet Explorer version 
4.0 or later usually support Cascading Style Sheets. When exporting screens and forms to 
HTML in DB/TextWorks, you are asked whether you want to use CSS to preserve the 
formatting you specified in the designer.  

CGI 
Common Gateway Interface. A specification for how an HTTP server communicates with 
external programs. A CGI executable file provides the connection between browser 
software and an application. Most HTTP servers support CGI. 
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choices drop-down list 
An option that you can add to a field on a query screen to show a list of indexed terms 
when viewed on the Web. When the HTML page is viewed in a Web browser, users can 
open the drop-down list and select an item for which to search. 

compulsory form sort 
Sort description defined for a form, specifying the only way in which records can be sorted 
when that form is used. 

content validation 
Validation rules governing what can be placed in a field entry, including mask validation, 
minimum and maximum values, or a list of valid terms. 

criteria 
See search criteria. 

CSS 
See Cascading Style Sheet. 

DB/Text WebPublisher PRO 
A Web-based application that enables you to publish textbases on the Internet or an 
intranet, so Web users can search and edit them. WebPublisher PRO accepts queries from 
standard Web browsers, such as Microsoft Internet Explorer, and accepts XML input. The 
software returns results in dynamically generated HTML reports or XML. WebPublisher 
PRO is used together with DB/TextWorks, which is the “buildware” for creating 
searchable and editable textbases. 

DB/TextWorks 
A textbase system—a type of database software that enables you to build networked and 
standalone textbases to manage text, numbers, dates, and electronic images. DB/TextWorks 
combines traditional database power, including the ability to manipulate data and perform 
arithmetic calculations, with the ability to handle large amounts of text. DB/TextWorks is 
the database software that you use to build the textbases (text databases) that you can use 
with WebPublisher PRO to publish on the Internet or an intranet. 

Delete record link 
A link that opens the current record in an edit screen from which the user can delete the 
record. Compare Duplicate record link, Edit record link, New record link. 

Display form 
A form used to display one record at a time. Compare Report form, Edit form. 
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drop-down list 
See choices drop-down list. 

Duplicate record link 
A link that creates an editable copy of the current record on the screen. When saved, the 
copy is saved as a new record. This type of link can only be created by using a New record 
link on a Web edit form. Compare Delete record link, Edit record link, New record link. 

Edit form 
A form used on the Web for modifying a record. Compare Display form, Report form. 

Edit record link 
A link that opens the current record in an edit screen from which the user can make 
changes. Compare Delete record link, Duplicate record link, New record link. 

editable box 
A box on an Edit form in which you can add or change information. The box can contain 
only one field, which cannot be protected by the current password. 

elements 
See textbase elements. 

entry boundary 
The boundary where one entry ends and another begins. The entry boundary is indicated by 
an entry separator. 

entry separator  
(1) Text specified in a form to separate the entries in a field. 

(2) Pipe character (|) used to separate field entries on a Web edit form. 

See also field entry delimiter. 

Expand record link 
A record link that provides a hypertext link to a single-record display form. See also 
expanded display. 

expanded display 
Display of a single record at a time in a Web browser, when a user clicks on a hypertext 
link in a report form. See also expand record link. 

extension 
Part of a file name that is commonly used to signal the file’s purpose, such as log files 
(.LOG) and exported forms (.XPF). 
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field 
Part of a record containing a specific category of information, such as an author’s name or 
a publication date. 

Field Access password 
Password with an associated set of permissions, granting or denying read or read-write 
access to particular fields or records, or to the textbase itself (including textbase elements).  

field entry 
An item of information in a field. A record can contain more than one entry in a field, such 
as a Subject field having multiple subject terms. 

field entry delimiter  
Character used on a Web edit form to indicate where one entry ends and another begins. 
The field entry delimiter for WebPublisher PRO is the pipe character (|). See also entry 
separator. 

field name 
Text identifier for a field in a textbase. A name can be up to 20 characters and can contain 
letters, digits, spaces, hyphens, and underbars. 

field type 
Property of a field that governs how its contents are treated. A Date field, for example, is 
expected to contain dates, and will file dates chronologically. 

file URL 
An addressing scheme that does not specify a protocol (such as HTTP) for accessing files. 
File URLs are specific to a local system, such as an intranet. Example: 
file://server1/docs/myfile.htm. See also URL. 

fixed text 
Text added to the contents of a box in a form definition. Fixed text always appears when 
the form is used. 

form 
A layout for presentation of some or all of the information in a record. 

form box 
A box on a form containing field information, variables, or other information. 

FTP  
File Transfer Protocol used for sending data from one system to another on TCP/IP 
networks, including the Internet. 
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<head> section 
The top-most part of an HTML page/report, often including <title>, <script>, and <style> 
elements. 

hidden field 
Field to which all access is denied by the current password. 

HTML 
Hypertext Markup Language. HTML is a collection of tags used to mark blocks of text and 
assign attributes to them, to make them appear a certain way when viewed in a Web 
browser. 

HTML edit page 
An edit screen created by exporting an edit form to HTML. This method enables users to 
directly access the edit page via HTTP to add records. Users cannot modify or delete 
records using an HTML edit page. 

HTML search page 
See query screen. 

HTTP 
Hypertext Transfer Protocol, which is used for distributing hypertext documents on the 
Internet. HTTP is layered on top of TCP/IP. 

hypertext link 
The connection between one hypertext document and another. When a user clicks a 
hypertext link, a jump is made to another HTML page. 

image  
A file containing a picture, diagram, or scanned document that can be referenced in a 
textbase record and displayed or printed. 

Image link 
An image linked to a form though a hypertext link. See also hypertext link. 

index streaming 
Technology that downloads only the portion of information needed, to minimize load on 
the server. The Word Wheel uses index-streaming technology. 

INI file  
Initialization file, which a software application uses to store various settings. 
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initial action 
The action that occurs when a textbase is opened using a particular menu screen option. 
Menu screens exported to HTML ignore all textbase boxes except those with an initial 
action of Saved Query. 

initial elements  
The forms, query screen, and/or record skeleton that are loaded when a textbase is opened 
using a particular menu screen option. For menu screens, the initial elements control the 
default forms used for the Web. 

initial report/display/edit form 
The form that is first used in the Web browser. The initial report form is applied when the 
user retrieves records. The initial display form is applied when the user expands a record by 
clicking a hypertext link. The initial edit form is applied when a user clicks a New record, 
Edit record, or Delete record link to open an edit screen so they can add, edit, or delete a 
record. 

inline image 
An image that is displayed as part of a form, instead of as a separate page. 

Inmagic Choices Browser 
A window used on the Web to paste items from a validation list into an edit screen. The 
Inmagic Choices Browser is accessed by clicking a validation list link on an edit screen. 

InmagicADVANTAGE 
The software maintenance program of Inmagic, Inc. through which new features are made 
available to customers throughout the year as they are implemented, rather than as a 
once-a-year upgrade. New product releases are downloaded directly from the Inmagic Web 
site (www.inmagic.com). For more information, contact Inmagic, Inc. or your authorized 
Inmagic dealer. 

Internet 
A collection of computer networks connecting users around the world. 

intranet 
A LAN (Local Area Network) or WAN (Wide Area Network) that is used in a manner 
similar to the Internet, using TCP/IP, Web browsers, HTML pages, and so forth. 

ISAPI 
Internet Server Application Program Interface specification. A high-performance 
alternative to Common Gateway Interface (CGI) executable files. Internet Information 
Services, the free Web server software provided by Microsoft, supports the ISAPI protocol. 
See also API. 
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Java 
A platform-independent programming language that is typically used on the World Wide 
Web. Java and all Java-based trademarks and logos are trademarks or registered trademarks 
of Sun Microsystems, Inc. in the U.S. and other countries. 

JavaScript (JScript) 
A scripting language created by Netscape that can be embedded into HTML documents for 
use on the Web. It can also be used in form scripts in DB/TextWorks. It is unrelated to 
Java. Compare VBScript. 

jump 
See hypertext link. 

lead textbase 
A textbase that serves as a template when designing a query screen for use with 
DB/Text WebPublisher PRO to search multiple textbases. The lead textbase contains the 
query screen definition and all of the pertinent information about the other textbases to be 
searched. 

leading logo 
An image at the top of a page. See also trailing logo. 

link 
See hypertext link. 

Link field 
A field in a primary textbase used to identify and link to a record in a secondary textbase. 

linked textbases 
Textbases that are associated by means of a Link field in the primary textbase and an 
associated field in the secondary textbase. This relational-like linking enables you to access 
record information from the secondary textbase while working in the primary textbase. 

live textbase 
A textbase that is in one location where both DB/TextWorks and WebPublisher PRO can 
share it. Compare this to the alternative of maintaining the textbase locally and copying it 
up to the HTTP server whenever you make changes. Note that we strongly recommend 
using a live textbase if you plan to let users edit over the Web (for example, to add or 
modify records). 

Master password 
A textbase-level password that must be defined before any other passwords are created. 
The Master password grants full access to all operations. 
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Match field 
See XML match field. 

menu 
A list from which you can select an activity to perform.  

menu screen 
A list of items, each of which initiates a predefined query. A predefined query appears on 
the HTML page as a regular hypertext link. Clicking on the text initiates the query. 

Menu Screen Designer 
The tool used to create menu screens. 

message box  
A message that informs you about error conditions, requests confirmation, displays 
warnings, and so forth. 

minimum height  
The fewest number of lines that will be displayed in a form box, regardless of the amount 
of information available for display. Unless the minimum number of lines is set to zero, the 
box will appear, even if it contains a field absent in a particular record or hidden by the 
current password. 

multiple-textbase query 
A query screen designed so users can search more than one textbase from it. Typically, the 
textbases being searched are similar in structure, with similar fields. 

nested Boolean 
The use of two or more Boolean commands to construct a search request, possibly with 
parentheses to control the order of operation. See also Boolean commands. 

New record link 
This type of link opens an empty edit screen from which a user can add a new record. 
Compare Delete record link, Duplicate record link, Edit record link. 

paragraph formatting 
In the Form Designer, an option that specifies whether paragraph breaks are added to the 
information placed in a form box. 

password 
A series of characters that you may be asked to type into a password box on a query screen 
or an edit screen on the Web. Passwords control what activities you may perform. 
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PDF 
Portable Document Format. PDF is considered the standard for electronic document 
distribution.  

picture box 
Box on a form containing a fixed image, or an image referenced in the current record. 

predefined query 
A query whose criteria are pre-specified. The user can execute the query, usually through a 
hypertext link, without having to enter query criteria. 

primary textbase  
Textbase you open explicitly, and which contains at least one Link field. A primary 
textbase can be linked to one or more secondary textbases, which are opened implicitly 
when you open the primary textbase. 

Public 
Denotes textbase elements (forms, query screens, sets, record skeletons) stored in a 
textbase file rather than in the user file. Public elements are available to all users. Forms 
must be saved as Public to be used on the Web. 

query 
Search criteria intended to retrieve records. 

query box 
Box on a query screen, which searches one or more fields. Users type criteria (that is, 
words, terms, or comparison expressions) in a query box to search for records. 

query screen 
The query screen contains boxes into which you type words, terms, or comparison 
expressions. Each box represents one or more fields to be searched. Also called a search 
screen. 

Query Screen Designer 
The tool used to create query screens for searching a textbase. 
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range search 
Search that looks for records that have information in a field that falls within a specified 
range of values, such as dates. For example, 2001:2002 searches for records from 2001 
through 2002. 

Raw HTML 
An item in a form that is intended to be interpreted by an Internet browser as HTML code. 

record 
Retrievable unit of information in a textbase, generally associated with some kind of item 
(for example, book, document, customer) or event (for example, sales order, problem 
report, task).  

record-level security  
The ability to restrict access (read/write, read, or none) to classes of records within a 
textbase. Classes are defined with the Access Control field. See also Access Control field. 

refresh sets  
Re-execute the search strategy for saved sets, in order to update the list of records retrieved 
to reflect changes in the textbase since the searches were last performed.  

report 
Layout for presentation of multiple records found as the result of a Web search. A report is 
displayed when a user presses the Submit Query button on a Web query screen. Tabular 
reports (which present information in rows and columns) are often used on the Web. 

report form 
A form for displaying multiple records at a time, one after another (for example, as a table). 
Compare Display form, Edit form. 

Rewind (<<) button 
A button automatically added to screens and forms used on the Web that returns you to the 
last screen of a different type. For example, if you have been viewing records one at a time 
in a display page, the Rewind (<<) button will return you to the report page from which 
you accessed the display page. If you click the Rewind (<<) button again, you will be 
returned to the query screen from which you initiated your search. 

schema  
A specification describing the tags in an XML document. It details the relationship between 
the attributes and elements of an XML document.  

screen  
See query screen; menu screen.  
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search criteria  
All of the information typed or pasted in a query screen to find records. 

search screen 
See query screen. 

secondary textbase  
A textbase that is accessed indirectly through a Link field in a primary textbase. See also 
linked textbases.  

set  
A list of records found by a search, together with the criteria that were used to perform the 
search.  

style sheet 
See Cascading Style Sheet, XSL. 

TCP/IP 
Transmission Control Protocol/Internet Protocol. TCP/IP is the basic communication 
protocol that is the foundation of the Internet. All other protocols (such as HTTP, FTP, and 
Gopher) are layered on top of TCP/IP. 

text box 
A box on a form, query screen, or menu screen containing static text. 

textbase 
A collection of records containing related information. See also record, textbase structure.  

textbase default sort 
A sort that is defined as part of the textbase structure. 

textbase elements  
Forms, query screens, record skeletons, and sets. See also Public. 

textbase file  
The main textbase definition file (.TBA), which contains public textbase elements (sets, 
forms, query screens, and record skeletons). 

textbase structure  
List of fields and settings that define a textbase. 
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trailing logo 
An image at the bottom of a page. See also leading logo. 

UNC 
Universal Naming Convention. The actual name of a drive (for example, 
\\SERVER\VOL2), rather than the drive letter (for example, C:\). Recommended on 
networks and in other situations where drives might be remapped. 

URL 
Uniform (or Universal) Resource Locator. A naming, or addressing, convention used to 
locate a site on the World Wide Web or launch a file in its native application. Example: 
http://www.inmagic.com. See also file URL. 

validation list link 
A link on an edit screen that, when clicked, opens the Inmagic Choices Browser from 
which users can paste valid terms from a validation list into an edit box. 

VBScript 
A scripting language created by Microsoft that can be embedded into HTML documents 
for use on the Web. It is a subset of Microsoft’s Visual Basic programming language. 
Compare JavaScript.  

Web (WWW)  
World Wide Web. A network document delivery system that uses HTML as the authoring 
language and HTTP as the transport protocol. Developed at CERN in Switzerland, the 
European laboratory for particle physics. 

Word Wheel 
A dialog box that can be displayed in a Web browser to show indexed words or terms in 
the current field. Users can paste words and terms from the dialog box and search for them. 
Word Wheels make searching easier and eliminate trial-and-error searches. 
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XML  
Extensible Markup Language. Used for structured documents and data on the Web. XML 
uses tags, like HTML, but offers greater flexibility because it gives you the ability to define 
custom tags.  

XML match fields 
Match fields uniquely identify a record in the textbase. XML match fields are defined in 
the textbase structure. 

XSL  
Extensible Stylesheet Language. Used to create a style sheet to describe the formatting of 
XML data when it is displayed via a Web browser. An XSL style sheet specifies where 
information should appear on a page, as well as which fonts, styles, and other formatting 
attributes should be used. XSL style sheets are also used to transform XML files into 
Inmagic tagged format for the purpose of importing XML files. See also Cascading Style 
Sheet. 
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Index 

A C 
Cars textbase, 6, 73 Access rights, 70 

Adding boxes CARSXTRA.HTM, 51 
to forms, 29 Changing forms, 86, 87 
to menu screens, 29 Checklist, 71 
to query screens, 29, 80 Choices Browser window, 9 

Choices drop-down list. See Drop-down lists Adding drop-down lists 
to query screens, 44 Client/server, 5 

Adding hypertext links Company logos, 24, 40, 55 
to query screens, 57 Convert content to HTML file reference, 29 

Adding Word Wheels, 43, 80 Create field name map, 47 
Alternate link text, 29 

for image links, 62 D Applications, launching, 29 
Aspect ratio, 64, 68 Databases. See Textbase 
Automatically populating a field, 36 DB/Text WebPublisher PRO 

[WebPublisher Defaults] section, 66 
B [WebPublisher Textbase Paths] section, 66 

create forms using DB/TextWorks, 20 
Batch operations, 82 defined, 1 
Boolean searches features, 3 

adding AND-OR-NOT drop-down lists, 80 hardware configurations, 5 
troubleshooting, 86 online help, 6 

Box Properties using, 4, 63, 73 
forms, 23 Word Wheels, 7 
HTML, 29 XML match fields, 19 
menu screens, 57 DB/TextWorks 

and DB/Text WebPublisher PRO, 5 query screens, 39, 43, 45 
Boxes defined, 1 

adding to forms, 29 online help, 78 
adding to menu screens, 29 using, 78 
adding to query screens, 29, 80 DBTEXT.INI, 70 

Buildware. See DB/TextWorks DBTWPUB.INI, 68 
 explained, 64, 70 

textbase file locations, 66 
 DBTW-WPD virtual directory, 64 
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Default Files 
file locations, 63, 66 access rights, 70 
textbase paths, 66 documentation and samples, 6 
Word Wheel behavior, 44 HTML help pages, 14 

Default values, 36 HTML search screens, 68 
Delete record link, 33 images, 61, 64 
Directories, publishing textbases, 66 initialization, 70 

locations. See Locations Documentation, 6 
Drop-down lists publishing a textbase, 63, 66 

about, 8 textbase, 66 
adding to query screens, 44 WEB_*.HTM, 14 
Boolean AND-OR-NOT, 80 Fixed image, 68 
choices drop-down list, 7 Fixed images, displaying on the Web, 59 
forms, 41, 56, 58 Form boxes, HTML properties, 27 
query screens, 7 Forms 

adding logos to, 24 
Box Properties, 23 E create using DB/TextWorks, 23, 78 
displaying record images, 60 Edit record link, 33, 79 
do not appear in browser drop-down list, 87 Edit screens, 33 
expand record link, 13, 30 Editing 
exporting to HTML, 37 create HTML edit forms, 37 
fixed images, displaying, 59 menu screens, 58 
HTML properties, 25, 26 password for Web, 17, 27 
Raw HTML, 28 query screens, 51 
See Also links, 32 records, 82 
troubleshooting, 86, 87 Editing over the Web, 33 
validation list links, adding, 34 passwords, 17, 27 

security, 17 
G Error messages, 14, 85 

Execute Query, 11 
GIF, 61, 64 Exercises, 73 

Expand record link 
about, 13 H add to report, 30 

Expired query, 86 Help 
Exporting designing forms, 78 

edit forms to HTML, 37 HTML pages for users, 14 
menu screens to HTML, 58 knowledgebase and Web site, 6 
query screens to HTML, 50, 80 online help, 6 

README file, 6 
F Technical Notes, 6 

 
Field Access password, 17  
Fields, textbase record images, 61  
File locations  

images, 68  
logo and background images, 69  

File URLs, 29, 61  
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HTML Internet, publishing on, 63 
adding links to query screens, 57 Intranets 
exporting edit forms to, 37 defined, 65 
exporting menu screens to, 58 publishing on, 29, 61, 65 
exporting query screens to, 50, 80 
help for users (WEB_*.HTM), 14 J HTML properties, forms, 23 
HTML properties, query screens, 39 Java, 86, 87 
HTML query (search) screens. See Query 

screens 
JavaScript, 86, 87 
JPEG, 61, 64 

in form boxes, 28 Jumps. See Links 
Screen Properties, 80 
See Also search link, 32 K Treat text as, 57 

HTML file reference, 29 
Knowledgebase, 6 HTML properties, 54 

form boxes, 27 
L forms, 23, 25, 26 

menu screens, 54, 56 
LAN/WAN topology, 5 query boxes, 42 
Launching applications on an intranet, 29 query screens, 41 
Lead textbase, 47 text boxes on forms, 27 
Leading logo text boxes on menu screens, 57 

forms, 24 text boxes on query screens, 42, 46 
menu screens, 55 HTTP, access on intranets, 29 
query screens, 40 Hypertext links 

Links adding to query screens, 57 
adding to query screens, 57 

Lists. See Drop-down lists I Locations 
HTML search pages, 68 If empty use, 36 
initialization files, 70 Image file locations, 68, 69 
intranet publishing, 65 Image links, 61 
textbases, 63, 66 Images 

Logos file locations, 61, 64 
add to forms, 24 for the Web, 59 
add to menu screens, 55 GIF, 64 
adding to query screens, 40 JPEG, 64 

Index streaming, 43 
M Indexing, 44 

Initialization files, 70 
Maintaining textbase records, 82 DBTEXT.INI, 70 
Mapping fields, 47 DBTWPUB.INI, 64, 66, 70 
Match fields, 19 INMAGIC.INI, 70 
 Inline images, 61 
 Inmagic Choices Browser window, 9 
 INMAGIC.INI, 70 
 Input schema, 6 
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Query boxes Menu screens 
HTML properties, query screens, 42 about, 53 

Query screens adding logos to, 55 
adding boxes to, 80 create for the Web, 53 
adding drop-down lists, 44 displaying fixed images, 59 
adding hypertext links, 57 editing, 58 
adding logos to, 40 exporting to HTML, 58 
adding Word Wheels, 43 HTML page locations, 68 
Box Properties, 39, 43, 45 HTML properties, 54, 56 
creating and editing, 51, 80 illustration, 10 
creating using DB/TextWorks, 39 Raw HTML, 28 
defined, 2, 80 Messages, error, 14, 85 
displaying fixed images, 59 Modifying records 
drop-down lists, adding, 7 batch, 82 
exporting to HTML, 50, 80 over the Web, 33 
HTML page locations, 68 Multiple-textbase search, 3, 47 
HTML properties, 39, 41 
passwords, 45 N search multiple textbases, 47 
Word Wheels, adding, 7 Network file access, 29, 65 

Query sets, 53 New record link, 33 
New Search button, 14 

R Next Record buttons, 14 

Raw HTML, forms, 28 O README file, 6 
Record image, 68 Options, 70 
Record images, displaying over the Web, 60 
Records P displaying after a search, 75 

editing over the Web, 33 
Passwords editing, batch, 82 

adding to query screens, 45 textbase record images, 61 
on Web editing form, 27 Reports 
using over the Web, 17 creating, 78 

Permissions, 70 displaying records after a search, 75 
Predefined queries, 10 expand record link, 13 
Preferences, 70 troubleshooting, 86, 87 
Previous Record buttons, 14 Results of a query 
Publishing textbases editing over the Web, 12 

file locations, 66 viewing, 11 
instructions, 63 Rights, 70 
on an intranet, 29, 61, 65 

S Q 
Sample textbase, 6 

Queries Saving sets, 54 
editing results over the Web, 12 Schema, 6 
predefined, 10  
sorting results, 18  
viewing results, 11  
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Screen Properties location, 66 
forms, 23 passwords, 16 
HTML, 80 publishing on an intranet, 29 
menu screens, 54 publishing on the Internet (Web), 20, 63, 66 
query screens, 39 record images, 61 

Search screens. See Query screens search multiple, 47 
Searching sort order, 16 

adding predefined search links, 53 supplied, 6 
adding See Also search links, 32 troubleshooting, 71 
Boolean AND-OR-NOT drop-down lists, 80 Web options, 16 
creating query screens, 80 XML match fields, 16 
editing query screens, 51 Trailing logo 
for textbases, 67 forms, 24 
help for users, 14 menu screens, 55 
HTML page locations, 68 query screens, 40 
multiple textbases, 3, 47 Treat content item as 
selecting items from a list, 44 HTML file reference, 29 
selecting items from a Word Wheel, 43 See Also search link, 32 
troubleshooting, 86 Treat text as, HTML properties, 57 
tutorial, 74 Troubleshooting, 71, 85 
using predefined searches, 53 Tutorials, 73 

See Also search links, 32 
Server problems, 85 U Sets, query, 53 
Show terms by default, 44 UNC, 29, 66, 85 
Silent password, 17 URLs 
Single record display. See Expand record link constructed by WebPublisher PRO, 64 
Sorting over the Web, 18 file, 29, 61 
SpacedRelOps setting, 86 Use alternate link text, 29 
Specify number of entries, 45 Use External File Reference, 61 
Specifying the lead textbase, 47 Use file:// reference for image, 62 

Users 
T defined, 2, 5 

how they get help, 14 
Technical Notes, 6 
Term indexing, 44 V Test checklist, 71 
Text boxes Validation list links 

HTML properties, forms, 27 adding to forms, 34 
HTML properties, menu screens, 57 turning off, 35 
HTML properties, query screens, 42, 46 using on the Web, 34 

Textbase Validation lists 
administrator, 2 about, 9 
creating, 15 links, 7 
designating as lead, 47 Virtual directory, 64 
designer, 2  
editing over the Web, 33 

 editing records, batch, 82 
files that make up, 66 
indexing, 44 
lead, 47 
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W 
Web browsers 

editing records over the Web, 3 
how to get help, 14 
searching a textbase, 3 
using drop-down lists, 44 
using to search, 7 
using Word Wheels, 43 

Web editing, 33 
WEB_*.HTM, 14 
Webmaster 

defined, 2 
tasks of, 63 

WebNewSearchButton parameter, 14 
WebPublisher PRO. See DB/Text WebPublisher 

PRO 

Word indexing, 44 
Word Wheel 

about, 8 
adding to query screens, 43, 80 
explained and illustrated, 7, 43 
query screens, 7 
requirements, 7, 83 
troubleshooting, 87 

X 
XML 

how to use, 6 
input schema, 6 
match fields, 19 
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