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Chapter 1: Introducing DB/Text for Libraries

What is DB/Text” for Libraries?

It is a set of textbases, used within Inmagic” DB/TextWorks®, designed for the unique
needs of library professionals. All you have to do is load your own records into the
textbases. When you have done that, you are ready to start searching for information—
for example, using the CATALOG textbase—finding records, and displaying and
printing the results.

DB/Text for Libraries includes query screens designed for each textbase, to make
searching easier. It also includes forms for displaying and printing the records that you
find. There are forms for generating catalog cards, sending overdue notices, and many
other managerial and record-keeping tasks.

Additionally, DB/Text for Libraries includes menu screens, which provide a shortcut to
opening a textbase. You can make one of these menu screens appear when you start
DB/TextWorks. When you click one of the operations listed on the menu screen (for
example, Catalog journals, Order journals), the associated textbase opens with
appropriate forms and query screen pre-selected.

To help you further, DB/Text for Libraries includes an extensive online help file that
describes each textbase, query screen, form, and menu screen; and provides techniques
and suggestions for handling library processes and workflow. The help file, together
with this document, provide all of the information you need for DB/Text for Libraries
to help you use DB/TextWorks to manage your information center.

DB/Text for Libraries textbases, forms, and screens are ready for use in libraries of all
kinds, particularly those in corporations, law firms, hospitals, museums, and
government offices; plus university, public, and school libraries with special
collections or special projects. You can use the textbases, forms, and screens exactly as
they are, tailor them to your requirements, or use them as models when you design your
own.
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You use DB/Text for Libraries in conjunction with the Inmagic DB/TextWorks
software, to do things such as modify the textbase structures, add records to a textbase,
search for and display records, and print reports. DB/TextWorks and DB/Text for
Libraries combine to give you a ready-to-use framework to get a number of library
textbases up and running quickly, to use them in the operation of your library, and to
print reports.

All Inmagic software, including DB/TextWorks, has been designed from the start with
features important to librarians, including the ability to sort and print Library of
Congress, Dewey Decimal and UDC classification numbers correctly, to ignore leading
articles when filing, and to provide punctuation specified by AACR2 and other
standards organizations.

We at Inmagic, Inc. believe that you will find the combination of DB/TextWorks and
DB/Text for Libraries to be a valuable tool in your library or information center. We
are committed to continuing to improve our products to keep pace with advances in
technology and the changing needs of our customers. We welcome your ideas and
suggestions for future versions of both DB/TextWorks and DB/Text for Libraries.

Questions regarding any Inmagic product should be addressed to Inmagic, Inc. or your
local authorized Inmagic dealer.

Inmagic, Inc.

800 West Cummings Park

Woburn, MA 01801-6357

U.S.A.

Tel.: 781-938-4442 or 800-229-8398
Fax: 781-938-6393
http://www.inmagic.com

support@inmagic.com - product support questions

advantage@inmagic.com - InmagicADVANTAGE questions (from current customers)
consulting@inmagic.com - consulting services for individual projects
sales@inmagic.com - sales and pricing questions

marketing@inmagic.com - marketing questions

partners@inmagic.com - new Business Partner inquiries

webmaster@inmagic.com - messages related to the Inmagic Web site
wishlist@inmagic.com - feature requests

inmagic@inmagic.com - other messages
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Overview

DB/Text for Libraries uses separate textbases for library operations, and uses bar code
technology to track circulation (or you can manually do this if you do not use bar
codes). DB/Text for Libraries comes with the following textbases:

CATALOG. You use this textbase for cataloging information resources (no matter
what kind), for ordering materials of all kinds, and as an online catalog for your
customers.

SERIALS. You use this textbase as a serials management tool, for checking in
newly received issues, routing them, or claiming them from the supplier when they
have not been received.

LOANS. You use this textbase to track circulation of information resources.

SUPPLIER. You use this textbase to store the names and addresses of all your
suppliers.

BORROWER!. You use this textbase to store the names and addresses of all your
library or information center users.

ILL. You use this textbase to manage interlibrary loan requests.

ILLENDER. You use this textbase to store the names, addresses, and policies of
the organizations that loan materials to you.

The CATALOG textbase contains one record for each title (book, journal, and so
forth) in the library or on order. Transactions involving the individual copies are
managed in separate textbases (SERIALS and LOANYS).

Links between the CATALOG textbase and the SERIALS and LOANS textbases allow
information to be shared among the textbases, without requiring duplication of effort.
Separating the loan and serials transactions from the online catalog can improve
response time for all users of the library system.
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Other links among the other textbases are designed to reduce or eliminate redundancy
of information. For example, borrower names are kept in the BORROWER textbase,
but they can be accessed from the CATALOG, LOANS, and ILL textbases.

The ILL and ILLENDER textbases are used for interlibrary loans. They can be ignored
or deleted if this is not a function you would use.

For more about the textbases, see “Textbases” on page 13.

4 Inmagic DB/Text for Libraries: A Model for Automating Your Library



Chapter 2: Getting Started

Before using DB/Text for Libraries with DB/TextWorks, make sure that you have the
following available to you:

e DB/TextWorks Version 5.1 or higher already installed on your computer.

o [nmagic DB/TextWorks User’s Manual.

e Microsoft Internet Explorer 5.0 or later already installed if you plan to use features
such as Inmagic.NET" or Thesaurus. It does not have to be your default browser.

e The Inmagic DB/Text for Libraries CD-ROM.

Installation

You can install the DB/Text for Libraries files in any location. We recommend using a
new, empty directory, which you can specify during the DB/Text for Libraries
installation procedure.

To install DB/Text for Libraries
1. Insert the Inmagic DB/Text for Libraries Setup CD-ROM in the drive.

2. Setup should automatically start. If not, from the Windows Start menu, choose
Run, then type the CD-ROM drive letter followed by the SETUP command (for
example, E: \ SETUP, then click OK).

3. Follow the prompts to complete the installation.

Chapter 2: Getting Started

5



The Setup program unpacks and copies files to the destinations that you specify. These
include the following file types:

e Textbase files. Each textbase is composed of a number of files, each with the same
name but a different extension. For example, the LOANS textbase includes
LOANS.TBA, LOANS.ACF, LOANS.DBS, LOANS.INI, and so forth. All of the
DB/Text for Libraries query screens, display forms, edit forms, and report forms
are contained within the textbase files. The query screens, forms, and skeletons do
not exist as separate files.

e Menu screen files. Several menu screen files (*. TBM) are included with
DB/Text for Libraries. To learn about them, see “Menu Screens Delivered with
DB/Text for Libraries” on page 18 and the online help.

e Optional validation lists. These ASCII text files (*.TXT) are validation lists that
you can import for use with a particular field. Other validation lists have already
been applied, and therefore are stored in the textbase files.

o PDF file. The DB/Text for Libraries: A Model for Automating Your Library
document, DBTfL.PDF (this document).

e Online help. The DB/Text for Libraries online help is made up of two files
(DBTLIB.HLP and DBTLIB.CNT).

Note that you have the option of installing empty textbases (ready to receive your own
data) and sample textbases (containing records you can use to become familiar with the
product).

What’'s Next?

After installing the DB/Text for Libraries files, to open DB/Text for Libraries, from
the Start menu, choose Programs>Inmagic Applications>DBText for Libraries.
Unless you have installed the sample textbases, only the SUPPLIER textbase already
contains records. Your first task should be to familiarize yourself with the textbase
structures and to decide if you want to make any changes. In most cases, you should
make those changes before adding records to the textbases.

You should also familiarize yourself with the online help, because it contains all the
information you need to use DB/Text for Libraries. This document (Inmagic DB/Text
for Libraries: A Model for Automating Your Library) mainly provides an overview.
After opening a DB/Text for Libraries textbase, choose Help> Help on DB/Text for
Libraries. For example, look up help topic “First Steps,” which has suggestions on
how to proceed and other important information, and “Library Operations,” which
includes links to step-by-step instructions on ordering, cataloging, managing serials,
and other tasks.
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After making changes (or deciding that changes are not needed), you are ready to start
adding records to the textbases. You can also take a look at the query screens, forms,
and menu screens. Because they were created with a diverse group of users in mind,
you may want to customize them to meet your specific needs. For more information
about adding records and changing elements, such as forms, see Chapter 4,
“Customizing the Textbases,” on page 23.

Note: Where possible, DB/Text for Libraries screens have been designed to fit
horizontally within a screen resolution of 800 x 600 pixels or higher. Also, screens
have been designed to work with a color palette of greater than 256 colors. If, for
example, logos do not display correctly, check the color palette setting for your
machine. For example, for Windows NT machines, use 65536 Colors; for Windows
2000 machines, use High Color (16-bit). You adjust these settings on the Windows
Display Properties dialog box.

Where to Find Information

A number of sources are available to help you use DB/TextWorks and
DB/Text for Libraries effectively.

o DB/TextWorks comes with a user’s manual and its own online help file.

e DB/Text for Libraries comes with this document (DBTfL.PDF, which was copied
to your machine during the DB/Text for Libraries installation process) and an
extensive online help file.

The Inmagic DB/TextWorks User’s Manual

The Inmagic DB/TextWorks User’s Manual is the primary source of information on the
DB/TextWorks software. We recommend that you perform the exercises at the end of
Chapter 1 (the “Quick Tour”). This is a quick and easy way to get acquainted with the
software.

DB/Text for Libraries: A Model for Automating Your Library

The DB/Text for Libraries: A Model for Automating Your Library document provides
an overview of the DB/Text for Libraries components, discusses the benefits of library
automation, and describes which library activities can be automated. The DB/Text for
Libraries: A Model for Automating Your Library document is intended to be used in
conjunction with the DB/Text for Libraries online help file. It is intended to be used
with the DB/TextWorks documentation, not as a replacement for it.

Chapter 2: Getting Started
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The Online Help

When you open a DB/Text for Libraries textbase in DB/TextWorks, you have access to
two help files:

DB/TextWorks help. This help file explains DB/TextWorks operations. To access
this help file, choose Help>Help Topics, or press F1, or click the Help button on
any dialog box. You recognize this help file by its title, “Inmagic DB/TextWorks
Help.”

DB/Text for Libraries help. This help file describes DB/Text for Libraries
operations and components. To access this help file from the menu screens
delivered with DB/Text for Libraries, click the Help button. Or, with a Libraries
textbase open, choose Help>Help on DB/Text for Libraries. Certain query
screens and edit forms may also have a ? button, which you can click to open the
Libraries help file. You recognize this help file when it is open by its title,
“Inmagic DB/Text for Libraries Help.”

The DB/Text for Libraries help file contains important information that is not covered
in this document. For complete information about how to use DB/Text for Libraries, be
sure to familiarize yourself with the information contained in the online help—
especially the topics on Library Operations and the textbases, forms, and query screens.

Note: Both files are standard Microsoft Windows help files. If you are not familiar
with using online help, open either help file as explained above and choose Help>How
to Use Help.
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Troubleshooting Help

If the Help on DB/Text for Libraries command appears disabled, make sure that the
textbase you are using has a textbase .INI file in the same directory as the textbase, and
that the .INI file contains the proper lines, as explained in the following section.

If the Help on DB/Text for Libraries command brings up a help file other than the
one for DB/Text for Libraries, or gives an error message when you choose it, modify
the textbase .INI file to specify the DBTLIB.HLP file, as explained in the following
section.

The Textbase .INI File

Each of the textbases has a textbase .INI file supplied with it. For example, the LOANS
textbase has a file called LOANS.INI. Each textbase .INI file contains the following
lines:

[Help]
HelpFileName=DBTLIB
Menu=Help on DB/Text for &Libraries

This tells DB/TextWorks that there is a textbase-specific help file called DBTLIB and
that the Help menu wording is Help on DB/Text for Libraries. Without
this .INI file, the Help on DB/Text for Libraries command would either be disabled
or would access a help file with the same name as the textbase (for example, a textbase
called LOANS would access the help file called LOANS.HLP, if it existed).

DB/TextWorks looks for the help file in the same location as the textbase.

Chapter 2: Getting Started 9



Sample Textbases

The installation CD-ROM includes a set of DB/Text for Libraries textbases containing
sample data. You can install these in a separate directory and use them to familiarize
yourself with the functions and reports. If you want to add or change screens or reports,
you can do so in these textbases, and see how your changes look with “actual” data.
When you are ready to enter your own information, search for the sample records and
delete them, or export your modified forms and import them to the empty textbases
(instructions are included with the online help).
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Chapter 3: Components of DB/Text for Libraries

DB/Text for Libraries consists of a number of textbases, forms, and files specifically
designed for use in a library, information center, or any other situation where it is
desirable to organize and make information resources available to a number of users.
These “library-specific” components all rely on the underlying power of the
DB/TextWorks textbase management system to create an automated library solution.

The major components of the DB/Text for Libraries application are listed below and
described in more detail later in this chapter.

Textbases. A textbase is a collection of records containing related information.
Several textbases are included with DB/Text for Libraries. Y ou may choose not to
use all of them. When you decide which textbases you will use (and optionally
make structural changes, such as renaming fields or changing validation), you are
ready to add records to the textbases.

Menu screens. A list of items that may appear when you start DB/TextWorks.
Clicking on one of the options on a menu screen either brings up another menu
screen, or opens a particular textbase with the appropriate query screen, forms, and
record skeleton pre-selected.

Query screens for each textbase. Screens that list the fields commonly searched
for a particular purpose. You can add other fields to a query screen as needed.

Edit forms for each textbase. Forms used in the Edit window when adding or
editing records.

Display forms for each textbase. Forms used in the Display window to display
one record at a time, after a search.

Report forms for each textbase. Forms used to display and/or print multiple
records. Some report forms are designed for use in the Report window, to view
multiple records after a search. Other report forms are designed for printing, and
others are for sending EMail. All of the forms have been designed specifically for
use in library operations.

Saved sets. Records found by a search are called a set. You can save a set to use
again later. The ability to save and re-use sets makes it easy to return to different
sets of information extracted from a textbase.

Chapter 3: Components of DB/Text for Libraries 11



e Record skeletons. Templates for creating new records, with some information
already filled in.

e Scripts. Procedures defined with forms and screens, enabling common operations
to require less effort on the part of the user. For example, a script can pre-populate
a query screen, move information among boxes on an edit form, and print a report
using a pre-specified design.

DB/Text for Libraries also includes documented procedures for the library operations

listed below. As with all aspects of the product, you are free to use those procedures

just as they are, or adapt them to meet the needs of your own organization. To review

the suggested procedures, refer to “Library Operations” in the DB/Text for Libraries

help file.

e  Ordering

e (ataloging

e Managing serials (check-in, routing, and claiming)

e Lending materials from the library collection

e Interlibrary lending

e Secarching

e Printing catalog cards, overdue notices, and reports of all kinds

e Sending reports/memos to library users via EMail

e Publishing the online catalog on an intranet (using DB/Text"” WebPublisher)

12 Inmagic DB/Text for Libraries: A Model for Automating Your Library



Textbases

DB/Text for Libraries contains several textbases. The textbases have been designed to
organize information about your library collection, library users, and suppliers. The
textbases are ready to use—you just have to add records. If you want to make changes
to the textbase structures, read Chapter 4, “Customizing the Textbases,” on page 23.

The textbases are described briefly below.

Tip! For full information about each textbase—including field definitions and narrative
descriptions—as well as a list of the query screens and forms available for each
textbase, refer to “Textbases” in the help file.

CATALOG Textbase

You use the CATALOG textbase to store one record for each title (book, journal, and
so forth). One record may represent multiple copies of the same title. CATALOG is
used directly for searching, ordering, and cataloging. The lending and serials
management functions are performed from separate textbases (LOANS and SERIALS,
respectively). Use the CATALOG textbase to:

e Order books, periodicals, or other materials

e Produce reports about acquisitions by supplier (vendor), department, and so forth
e Publish lists of newly received materials

e (Catalog the items in the collection: serials, monographs, research reports, journal
articles, audiovisual materials, and so forth

e Print book catalogs, authority lists, bibliographies, book label sets, expenditure
reports, and so forth

e Store current awareness searches and run them periodically, printing the results for
the requestor or sending them via EMail

e Inform people searching the catalog whether the items they are seeking are
available or out on loan

e Publish the catalog on your intranet using DB/Text WebPublisher

Chapter 3: Components of DB/Text for Libraries 13



SERIALS Textbase

You use the SERIALS textbase with the CATALOG textbase to handle serials checkin.
It stores one record for each copy of each active subscription. Use the SERIALS
textbase to:

e Set up arrival patterns for the issues you expect to receive

e  Check in and route periodical issues

e Claim missing issues from the supplier

LOANS Textbase

The LOANS textbase works in conjunction with the CATALOG textbase to support
the circulation of library materials. Bar codes or other unique item identifiers are used
to relate the item to the cataloging information for that item. The LOANS textbase
contains one record for each loan transaction (current or historical). Use the LOANS
textbase to:

e Lend items to borrowers

e Log the return of items on loan

o Notify someone waiting for an item of its availability

e Notify a borrower that an item is overdue, via printed memo or EMail
e Determine whether a departing employee has any items out on loan

e Produce statistical reports about circulation activity by department, title, category,
subject, and so forth (Use these reports to guide collection development and
support budget requests.)

BORROWER Textbase

You use the BORROWER textbase to store one record for each potential borrower or
person who may request that an item be ordered by the library. This textbase lets you
organize information about library users in one central file. Through links, borrower
information is used for lending, tracking purchase requests, and for interlibrary loan
requests. The CATALOG, LOANS, and ILL textbases use information from the
BORROWER textbase.
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SUPPLIER Textbase

You use the SUPPLIER textbase to manage information about publishers, book
wholesalers, subscription agents, document delivery services and other suppliers of
library materials. This textbase is used by the CATALOG and SERIALS textbases to
facilitate ordering, renewing, claiming, or canceling book and serial purchases.

The SUPPLIER textbase stores one record for each supplier from whom you order
books, serials, and so forth. If a given supplier has more than one address, create
separate records for each address and identify them uniquely in the Supplier field. For
example, create one record with Baker & Taylor (NJ) in the Supplier field and
another record with Baker & Taylor (NC) in the Supplier field.

ILL Textbase

You use the ILL textbase to manage the borrowing of materials or document delivery
from other libraries. The ILL textbase stores one record for each transaction or request.
Since ILL requests are for materials that are not available in your collection, it is not
necessary to combine information about ILL requests with the rest of your online
catalog. (You can do so, however, if you prefer.) A separate ILL textbase lets you
generate and track ILL requests without burdening the online catalog, and makes it
easy to delete records for ILL requests that have been fulfilled. The ILL textbase is
linked to ILLENDER, which contains the name, address, and lending policies of
organizations that provide materials to you.

ILLENDER Textbase

You use the ILLENDER textbase to organize the name, address, and notes, such as
lending policy information, for libraries that you use for interlibrary loans. The
ILLENDER textbase stores one record for each library with which you have this
relationship. This textbase can be opened directly or accessed by a link from the ILL
textbase.

Chapter 3: Components of DB/Text for Libraries 15



The following diagram illustrates the link relationships among the textbases that make
up DB/Text for Libraries. This diagram also illustrates the Link field(s) in each

textbase.
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Menu Screens

A menu screen is a list of options representing textbases or other menu screens that you
can open. Each menu screen supplied with DB/Text for Libraries consists of a list of
commonly performed operations, such as Cataloging, Ordering, and Searching.
Clicking on one of the options on the menu screen opens a particular textbase with the
query screen, forms, and record skeleton appropriate to a particular task pre-selected. A
menu screen option can also initiate a predefined query in the textbase.

A menu screen may appear automatically when you start DB/TextWorks, or you can
select a menu screen after starting DB/TextWorks but before opening a textbase.

Regardless of whether a menu screen appears when you start DB/TextWorks, you can
use the File menu to open a textbase and you can select forms, query screens, and
record skeletons to use for the current session.

For information about how to create, edit, select, and use menu screens, search the
DB/TextWorks online help for “Menu Screens” or look it up in the DB/TextWorks
User’s Manual. For information about the menu screens created specifically for
DB/Text for Libraries, including how to display your corporate logo on them, refer to
the DB/Text for Libraries online help.

Note: To return to a menu screen after opening a textbase, close the textbase in
DB/TextWorks by choosing File>Close, or click the Close toolbar button. Notice that
buttons on the menu screens provide ease of navigation among the menu screens.
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Menu Screens Delivered with DB/Text for Libraries

DB/Text for Libraries comes with the following menu screens:

Acquisition Functions (LIBACQ.TBM). This menu screen provides access to the
options available for the acquisition function organized by area (for example,
Ordering, Receiving, Supplier Maintenance).

Cataloging Functions (LIBCAT.TBM). This menu screen provides access to the
options available for the cataloging function organized by area (for example,
Cataloging, Searching).

Serials Functions (LIBSER.TBM). This menu screen provides access to the
options available for the serials function organized by area (for example, Issue
Tracking, Subscription Maintenance).

Lending Functions (LIBLOANS.TBM). This menu screen provides access to the
options available for the lending function organized by area (for example,
Transactions, Loan Maintenance, Borrower Maintenance, Interlibrary Loan).

Reporting Functions (LIBREPTS. TBM). This menu screen provides access to
the reports available for the reporting function organized by area (for example,
Loan Activity, Purchasing Activity, Catalog Reports).

Searching (LIBUSER.TBM). This menu screen illustrates how you might set up a
menu to help library users locate, view and print information from the online
catalog. This screen provides an easy way for users to do a quick or advanced
search, as well as search for recent arrivals. Also, a library user can save favorite
searches, and view his or her loans, periodical lists, and borrower information.

Notice that all these menu screens, except for the Searching menu, have a Help button,
which lets you easily access the online help for DB/Text for Libraries.

Note that you can adapt any of these menus to match the flow of work in your library.
You can add or delete items to suit your collection and mode of operation; specify
different query screens, forms, and record skeletons. You can also create entirely new
menus to suit your workflow.
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Query Screens

A query screen is a search screen that contains boxes into which you type words, terms,
or comparison expressions. Each box represents one or more fields to be searched. For
example, a box labeled Title might search the Title and Subtitle fields. To search those
fields, someone would type, for example, King Lear, into the box, and then execute
the query.

DB/Text for Libraries includes query screens for each of the textbases. These screens
are designed to help both information professionals and end-users retrieve information
from the textbases with ease. Searching with a query screen eliminates the need to
know each field name or learn a complex query language.

The query screens delivered with DB/Text for Libraries are meant as models that you
can use to create custom search tools for your own applications. Use them as is, or add,
delete, or reorganize the fields included in each query screen as needed.

Important! Many of the query screens have scripts associated with them. The online
help describes the scripts and which fields are required in order for them to work. If
you change any of the boxes used by a script, you may need to change the script as
well.

For more information, search the DB/TextWorks online help for “Query screens” or
look it up the Inmagic DB/TextWorks User’s Manual.

Edit Forms

An edit form is a form that can be used in the Edit window when you add or edit
records (choose Records>New Record or Records>Edit Record). DB/Text for
Libraries includes edit forms for each textbase to help you type information into a
record and revise the information in those records once entered. The edit forms can be
used as is or modified as you want.

Important! Some edit forms have scripts associated with them. The online help
describes the scripts and which fields are required in order for them to work. If you
change any of the boxes used by a script, you may need to change the script as well.
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In the CATALOG textbase, edit forms have been developed to support the data entry of
new order records, and to aid in cataloging those items when they arrive. Edit forms are
included for specific types of publications, such as journal articles, journals, and serials
other than journals. Use these as a guide to create edit forms for order entry and
cataloging that contain the specific fields you need for each type of library material that
you order and catalog regularly.

For more information, search the DB/Text for Libraries online help for “Forms.”

Display Forms

A display form is one that can be used in the Display window to view one record at a
time after a search (choose Display>Display Record).

For your convenience, several display forms have been provided for each of the
textbases. You can modify the forms or create additional ones to meet your needs.

For more information, search the DB/Text for Libraries online help for “Forms.”

Report Forms

A report form is a form that can be used to view and/or print multiple records after a
search. Some report forms are designed for use in the Report window (for viewing the
results of a search on the screen). Other report forms are designed for printing, and
others are for sending EMail.

DB/Text for Libraries includes many report forms for use in library operations. Report
forms are available to help you create book catalogs, catalog cards, research reports and
bibliographies, labels for books and file folders, and authority lists in card or book
format.

Order and serials management reports can generate order forms, claiming letters,
budget reports, new acquisitions lists, and routing slips.

Loan management reports track usage by borrower, department, and class. Overdue
notices and memos requesting return of library material are also included. Interlibrary
loan requests and reports detailing ILL charges also can be generated with reports
included with DB/Text for Libraries.
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The report forms can be used as they are or adapted for the special requirements of
your organization.

For a complete list of the forms provided with DB/Text for Libraries, see the “Report
forms” topic in the DB/Text for Libraries help file. For more information, you can also
look up this subject in the Inmagic DB/TextWorks User’s Manual and online help file.

To see how a form actually looks, do a search that will result in a small number of
records, then print the results, following the directions outlined in the help file. If the
printed results are not exactly what you want, modify the form.

Record Skeletons

A record skeleton is a template that contains information that you want to appear when
you create a new record in the Edit window. For example, a record skeleton might
insert the requestor’s name in every record created with that skeleton. Typically, you
select a record skeleton before creating several new records that contain some identical
information.

DB/Text for Libraries includes record skeletons for the CATALOG textbase. Edit the
skeletons before using them, to add the specific pieces of information that you want
entered in your order records.

To edit a record skeleton

1. Open the textbase that contains the record skeleton that you want to revise, then
choose Records>Edit Record Skeleton.

2. Select an existing record skeleton from the list.

3. In the Record Skeleton Editor, fill in the boxes so the record information contains
exactly what you want to appear in each new record.

You can specify literal text only. For example, you may want to enter a supplier
name, number of copies, the order date, a purchase order or internal account
number, or the name of the person who requested the material.

4. When you have finished, choose Record Skeletons>Save Skeleton.

For more information, see the Inmagic DB/TextWorks User’s Manual and online help
file.
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Inmagic.NET

DB/TextWorks also provides you with access to Inmagic.NET, which is an
Internet-connected environment that links the process of acquiring, cataloging,
indexing, and disseminating information throughout an organization. If you catalog
books or Web pages, you can use Inmagic.NET to catalog new bibliographic data, and,
in some cases, update existing records (for books procured through Inmagic.NET).

Note that Inmagic.NET is an evolving feature. New functionality may be presented
periodically. Therefore, for the latest information, see the on-screen text for the
function pages. You may also see a Help button on the toolbar and/or the page.
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Chapter 4: Customizing the Textbases

What does it mean to customize a DB/Text for Libraries textbase? It means:

*  You can change the textbase structure.

® You can change the forms, query screens, and record skeletons, and/or add new
ones.

e You can personalize menu screens (for example, add your corporate logo), or
create additional menu screens that suit your activities and workflow.

Typical changes to a textbase structure include renaming a field, adding a field,
changing the validation settings, and assigning passwords. Typical changes to a form
include re-arranging field order or changing font color and size. A typical change to a
query screen is adding one or more fields to be searched.

Until you add records to a textbase, it is just an empty structure. Of the textbases
supplied with DB/Text for Libraries, only the SUPPLIER textbase contains records.
The other textbases are empty. You need to add records to them, either by importing an
ASCII text file or by typing records one at a time. You can also add more records to the
SUPPLIER textbase if needed, or delete some of the ones that are there.

At installation, you have the option of installing textbases pre-populated with sample
data. If you start with these and make changes, you can delete the “dummy” records
before adding your own.

Modifying the textbase structures and the other components of DB/Text for Libraries is
easy and requires no programming on your part. With some planning and a little effort,
you can have the ideal system for the kind of information in your collection, the
manner in which you perform certain library operations, and the needs of your users.

Tip! DB/Text for Libraries uses scripts (for example, in query screens and edit forms)
and you may have created your own. Keep this in mind when you customize

DB/Text for Libraries, as you may need to change scripts that may be affected by a
customization.
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Changing the Textbase Structures

Every textbase has a structure, which is a list of fields and settings that determine how
the textbase will operate. These settings include, but are not limited to, field type,
validation, filing rules, password definitions, stop word lists, log file information, and
default sort orders. You can add, rename, and delete fields, change validation
requirements, and make other structural changes to adapt the textbases to your needs.

DB/TextWorks is a powerful textbase management system that allows you to change
almost any aspect of the textbase at any time. While the ideal situation is to design the
textbases carefully before you fill them with records or documents, it is possible to
make changes after you have populated a textbase. This gives you the flexibility you
need to change the textbase after you have had an opportunity to work with it, or to
change the design in response to some new need.

We recommend that you make structural changes before adding records to a textbase,
if possible. Although you can make structural changes after adding records, it is easier
and more efficient to make the structural changes first. (For example, changes in
validation rules for a field will apply to new records only.)

The Inmagic DB/TextWorks User’s Manual describes how to edit the textbase structure
and the impact of each type of change. Additional information, particularly appropriate
to DB/Text for Libraries, is provided below.

Important! We recommend that you review the DB/Text for Libraries textbase
structures carefully before you start to use them. Because they have been designed
to meet the needs of all sizes and types of libraries, the structures are quite complex.
There may be fields in the textbase structures that you will never use in your
application. You may want to add additional fields that you would like to have. You
may want to change the names of some fields to match the terminology that you use in
your library. (For example, change State to Province.) However, note that you can
change the forms and query screens rather than the field names. Not changing field
names makes it easier to apply DB/Text for Libraries upgrades in the future.

How to Make Changes to the Textbase Structures

To edit the structure of a DB/Text for Libraries textbase, open that textbase and choose
Maintain>Edit Textbase Structure. After editing the textbase structure, print a
description of it by choosing Maintain>Edit Textbase Structure and clicking the
Print Structure button. Make any additional notes documenting your changes, and
store them in a notebook. This information may be helpful to you or others in the
future.
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If you want to copy a textbase structure (thus retaining the original), choose File>New
Textbase, follow the prompts to name the new textbase, select Copy an Existing
Inmagic DB/TextWorks Structure, and indicate which textbase structure you want to

copy.

Assigning Passwords

You may want to protect your textbases from unwanted access. For example, you do
not want library users to be able to edit records in your online catalog. One way to
protect textbases is to place them in a directory to which users have read-only rights.
Another option is to use a Silent password to keep library users from seeing
confidential information and from editing the textbase structure or records. You may
also want to assign various passwords to library staff, for certain purposes. The
DB/Text for Libraries textbases do not have any passwords assigned to them. For more
information about assigning passwords, see the DB/TextWorks User’s Manual or online
help.

Tip! Some of the scripts used in DB/Text for Libraries manipulate information in other
textbases. Scripts in LOANS, for example, modify a field in the CATALOG textbase
when items are loaned out or returned, so that users searching the catalog can see if
items they are seeking are out on loan. If you add passwords restricting access to the
CATALOG textbase, the scripts may no longer work until modified to include the
appropriate password. Instructions for making this type of change are included near the
top of each affected script.

Adding or Deleting Fields

You can add fields to any of the textbases, as needed. New fields are added at the
bottom of the list of existing fields. You can change the apparent order of fields by
editing the query screens and forms.

If you are going to delete fields, you generally should do so before populating your
textbases with records. If you delete a field in a textbase that contains records, you
delete all of the information contained in that field in all of the records. We recommend
that you become thoroughly familiar with the textbase structures before you delete any
fields. Many of the textbases are linked together, and if you break a link by deleting a
Link or Associated field, it can have an unwanted effect in other textbases. Link fields
are clearly identified by their field type. However, Associated fields are not clearly
identified, because they do not have a particular field type. For more information about
linking textbases, see the Inmagic DB/TextWorks User’s Manual or online help.
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Note that you can remove a field you do not use from view (without deleting it from the
textbase definition) by removing the box representing that field from edit and query
screens. In general, you do not need to remove it from forms and reports, because
information that is absent does not appear.

Renaming Fields

Changing a field name is simple, even if the textbase contains data. Any forms or query
screens that include that field will continue to work properly. Links will continue to
work properly after changing field names. However, the following items may require
changes to reflect the new name:

e (Calculations involving that field, in a form or Computed field
e Forms that label information with the original name

e Scripts that manipulate the information in the renamed field
e Stored sets that search that field

Changing the Field Type

The field type (for example, Text, Number, Date) determines how information is
indexed. Each field type has its own default indexing and sorting rules. For example, a
Date field is expected to contain dates, and is the only field type that will sort dates
chronologically.

Each field in the DB/Text for Libraries textbases has been assigned a field type. Look
at each one carefully, and refer to the online help to see what information each field
was intended to hold, and the various ways that the information might be used.

Change any field type that seems inappropriate for your intended use. For example, if
you want to use the Class field for Universal Decimal Classification numbers, change
its field type to UDC.

Changing Validation

Validation settings define what kind of information will be permitted in a field when a
record is added or modified. If you make changes to the validation before adding
records, DB/TextWorks will ensure that the information that is entered into the
textbase is correct and consistent. For example, validation can ensure that a valid date
is entered in a Date field, or that a key field is never left empty.
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Several fields in the DB/Text for Libraries textbases use a validation list. For example,
two-letter abbreviations for each state in the United States are already associated with
the State field in the BORROWER, SUPPLIER and ILLENDER textbases, and the
CATALOG textbase has a validation list for the frequency of publication of serials.
Look at these validation lists, and others, to see if you want to accept each as it is,
modify it, or eliminate the use of the validation list for the field altogether.

Validation lists in ASCII format with abbreviations for Canadian provinces
(CANABB.TXT) and Australian states (AUSABB.TXT) have been included with
DB/Text for Libraries. To use them with the State field, import them. Choose
Maintain>Edit Lists>Validation Lists, select State from the list of Fields with
Validation Lists and click the Edit List button. Then use either the Merge File into
List button or the Replace List with File button. After doing this, you may want to
edit the textbase structure and change the name of this field.

Note that the Descriptors field (in the CATALOG textbase) is set up to use a validation
list to verify the information entered in that field. However, due to the wide variation in
subject headings used in libraries, we have not provided a validation list for your use.
You can either create a validation list for this field before you add records to the
textbase, so you can use the validation list when adding new records, or have
DB/TextWorks build this list for you when you import records.

To create a validation list for the Descriptors field
1. Open the CATALOG textbase and choose Maintain>Edit Lists>Validation Lists.

2. Select the Descriptors field, then type the subject headings that you want to use, or
use the Merge File into List button to import a validation list that you created and
saved as an ASCII text file.

Alternatively, if you have data in electronic form, ready to add to your textbase, you
can specify a validation list with overrides and updates permitted, then have
DB/TextWorks build the list for you by selecting the appropriate import options. Do
this in the Import Options dialog box by selecting the Validation tab, and then selecting
the Accept Overrides & Update Validation Lists option button.

Tip! You can also use the DB/TextWorks Thesaurus feature to provide a controlled
vocabulary for the Descriptors field. For information about the Thesaurus feature, see
the DB/TextWorks online help. Note that if you use the Thesaurus feature for the
Descriptors field, you should remove the validation setting for this field.
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Changing Forms, Query Screens, and Record Skeletons

Forms, query screens, and record skeletons are referred to as textbase elements. You
can redesign, rename, or otherwise change existing elements.

To print, rename, delete, import, or export elements, open the textbase that contains the
elements that you want to work with, then choose Maintain>Manage Textbase
Elements.

Changing Forms

To edit a form, open the textbase containing the form you want to change, and choose
Display>Design Form. Use the Form Designer tools to edit the form. Then choose
Form Operations>Save Form As, to save the form under its existing name or a new
name, and optionally change its description, purpose, or storage location.

For more information about changing forms, look up this subject in the /nmagic
DB/TextWorks User’s Manual or online help.

Changing Query Screens

To edit a query screen, open the textbase that contains the query screen you want to
change, and choose Search>Design Query Screen. The Query Screen Designer works
much the same way as the Form Designer.

For more information about query screens, look up this subject in the /nmagic
DB/TextWorks User’s Manual or online help.
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Changing Record Skeletons

To edit a record skeleton, open the textbase that contains the record skeleton you want
to change (only the CATALOG textbase contains record skeletons) and choose
Records>Edit Record Skeleton. Type text exactly as you want it to appear in a new
record, then choose Record Skeletons>Save Skeleton.

DB/Text for Libraries includes record skeletons for the ordering process. Edit the
record skeletons before using them, to add the specific pieces of information that you
want entered in each order record that you create (for example, supplier name, order
type, requestor).

For more information about changing record skeletons, look up this subject in the
Inmagic DB/TextWorks User’s Manual or online help.

Adding Record Information to a Textbase

Once you have reviewed the DB/Text for Libraries textbase structures and made any
changes that you think are necessary, you can add records to the textbase. There are a
number of ways to get information into the textbases:

e Type information directly into one record at a time.

e  Obtain information in machine-readable form, so it can be imported.

e Hire a service bureau to enter the information.

Type Information into One Record at a Time

Typing information into a textbase one record at a time may be a reasonable solution if
you have only hundreds of records to enter, but would not be effective for a large
library collection. In that case, investigate ways of getting the desired information
already in machine-readable form.
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Keying information into the textbase is a simple way to maintain a textbase after it has
been established. Information for all new orders can be entered, and that information
can provide the basis of the final cataloging record for the same title. To speed data
entry, you can use shortcuts such as record skeletons, substitution lists, batch modify,
copying fields from other records, and copying a whole record and then changing some
information in the new record. For more information on these techniques, see to the
Inmagic DB/TextWorks User’s Manual or online help.

Obtain the Information in Machine-Readable Form

The information that you want to incorporate into your textbases may already be
digitized. Look into various ways of obtaining that information, and the cost and time
involved in converting it to the format you need.

DB/TextWorks accepts ASCII delimited files (or .CSV files), a format commonly
available for exporting data from other software programs. You can import files that
are in ASCII text format into a DB/TextWorks textbase by choosing File>Import. This
is much faster than typing records one at a time, and is the most reasonable way to
build a large textbase. For important information about how to import records, see the
Inmagic DB/TextWorks User’s Manual or online help.

You should also read “Changing Validation” on page 26 before you start importing
records.

Inmagic.NET also lets you catalog new bibliographic data, and, in some cases, update
existing records (for books procured through Inmagic.NET).

Supplier Information

To help you get started, the SUPPLIER textbase contains records for a number of U.S.
book wholesalers and subscription agents. You can add more suppliers, or edit or delete
existing records as appropriate.

Name and address information on the suppliers from whom you purchase library
materials may be available somewhere in your organization in machine-readable form.
Perhaps orders have been produced up to now using word processing or database
management software on a PC. Or, if an Accounts Payable (A/P) department processes
invoices for library materials for you, they may be able to provide you with supplier
name, address, and account numbers from the A/P system. With a little effort, these
files can be massaged into Inmagic tagged format or delimited ASCII format, then
imported into the SUPPLIER textbase. For more information on importing records, see
the Inmagic DB/TextWorks User’s Manual or online help.
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Borrower Information

Information on the potential users of your library system is almost certainly available in
machine-readable form. Contact your Human Resources department for a list of
employees, employee numbers, and their departments. In an academic setting, the
Registrar may provide information on students who are authorized to use library
services. Or contact the Director of Information Systems, who may be able to provide
some or all of the information you need. Once you have the information in ASCII
format, you can edit the files using a text editor or word processor to make them
conform to Inmagic tagged format or delimited ASCII format, so they can be imported
into the BORROWER textbase.

Note that you will need to include EMail addresses for each borrower if you intend to
send overdue notices, reminders, and so forth via EMail.
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Final Words

Thank you for using DB/Text for Libraries and DB/TextWorks. Inmagic is proud to
help today’s information leaders deal with the information management needs that you
encounter daily. We believe that DB/Text for Libraries is a complete information
management solution because it can accommodate many information management
tasks that go beyond a library’s traditional role. Besides the traditional library uses for
DB/Text for Libraries and DB/TextWorks, you can use their many powerful features to
set up your own textbases for use either on your network or for Internet/intranet access.
For example, you can:

e Compile and publish competitive intelligence reports
e Research, retain, and keep current patent and trademark information
e Maintain archival and corporate records

e (Create Web page catalogs and “virtual library” links

A list of information resources outside the library is provided in the Appendix. You
may find the list useful as you think of ways to expand the resources for your library or
information center for the future.
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Appendix: List of Information Resources Qutside the
Library

The following list shows you information resources found outside the library that may

add value in a library textbase.

R&D Department
Internal R&D Reports
Product Literature
Overhead Transparencies
NTIS Technical Reports
Technical Journals
Conference Proceedings
Supplier Catalogs
Article Reprints

Data from External Sources
Manuals & Handbooks

Competitors’ Technical
Reports

Newsletters

Engineering Drawings
Industry Standards
Project Files

Test Results

Purchasing Department
Commerce Business Daily
Supplier Catalogs

Floor Plans

Contracts

Maintenance Agreements
Equipment Inventories

Supplier & Distributor
Information

Marketing Department
Client Lists

Marketing Studies
Census Information
Consultants’ Reports
Product & Service Directories
Advertising Campaigns
Marketing Plans

Audio & Video Tapes
Presentations
Competitors’ Price Lists

Competitors’ Product
Literature

Corporate Offices
Annual Reports
Planning Journals

AMA Publications
Company Manuals
Employee Handbooks
Competitive Intelligence
Newsletters

Business & Trade Journals
Company Archives
Business Plans

Budget Reports
Consultants’ Reports

Audit Reports

Correspondence, Faxes, EMail

Legal Department
Regulations

Case Files

Law Books

Legal Directories
Loose-leaf Services
Legal Periodicals
External Databases
Legal Memoranda

Information Systems
Department

Data & Program Tapes
Equipment Manuals
Software Manuals
Supply Catalogs
Service Agreements
Technical Standards
Wiring Plans
Equipment Inventories
Licensing Agreements
Newsletters

Computer Journals

Appendix: List of Information Resources Outside the Library
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